Problem to compile a program with V-USB library [SOLVED]

General discussions about V-USB, our firmware-only implementation of a low speed USB device on Atmel's AVR microcontrollers
Posts: 2
Joined: Wed Oct 03, 2012 8:55 am

Re: Problem to compile a program with V-USB library [SOLVED]

Post by Kristenastewart » Wed Oct 03, 2012 8:56 am

Problem "solved".

I'm still of the opinion that libraries for the AVR series should at least have some ability to set custom #defines, but by editing the source of the V-USB library to force the requisite #defines, that was fixable.

The problem with compilation for the 328p was very obscure (to me). I will quote the relevant portion of the V-USB forums:


I discovered that the cause is a change in the identifier of the INT0 vector. V-USB is using the outdated "SIG_INTERRUPT0" as default in usbdrvasm.S (Line 60) which is only supported by "old" headerfiles for "old" controllers. The headerfiles for the controller with a "p" only support the new identifier "INT0_vect". So the vector to the interrupt routine is not written into the vector table and unfortunately in this case you will not get any warning or error message

By changing that line, the code (which indeed compiled without error in both cases) built correctly and my device and library are working at what appears to be 100% in 0018.

Thanks for the help!

[link removed]

Post Reply