Does 2.0.2 uninstall properly?

General discussions about Little Snitch
Post Reply
Posts: 3
Joined: Thu Mar 20, 2008 3:33 am

Does 2.0.2 uninstall properly?

Post by Zeromus » Thu Mar 20, 2008 3:41 am


I installed v2.0.2 yesterday to have a play, but in the end decided to uninstall it. When I woke up today and read about the airport/time machine update I ran apple Software Update and found it could not connect, which was odd as I was connected and read about the update through safari, everything else could connect to the internet.

I tried everything and finally decided to try and reinstall Little Snitch. After reinstalling it and rerunning Software Update I got the normal pop up about asking if Software Update could connect, I allowed, and it worked fine. FYI I had not authorized Software Update or run Software update before uninstalling Little Snitch the first time.

I've since been playing with other applications to see what works and what doesn't, and now I can't get transmission to download anything with or without Little Snitch.

Anyone else run into anything similar to this? Heard of the best way to purge Little Snitch from my system completely?

FYI: I did uninstall Little Snitch properly using the uninstall button in the installer.


Posts: 3
Joined: Thu Mar 20, 2008 3:33 am

Post by Zeromus » Thu Mar 20, 2008 4:01 am

Okay, I did some searching on this board and found that the reason Transmission wasn't working was because apple python had to be allowed.

So I brought up Little Snitch rules, clicked new, then I chose a system process, went to bin, then selected python. After running that, I got the normal "Transmission wants to access, Allow?" box and it seems to be working.

...but this brings me back to my subject question. Does Little Snitch uninstall itself properly? btw I have the Apple firewall off (allow all incoming connections).


Posts: 1
Joined: Sat Mar 22, 2008 10:06 pm

Post by aikon » Sat Mar 22, 2008 10:09 pm

I'm having the same problem, I uninstalled the program using the installer app and now Amazon's MP3 downloader app doesn't work, keeps telling me that it can't find an internet connection, what's going on?

Posts: 3
Joined: Thu Mar 20, 2008 3:33 am

Post by Zeromus » Sun Mar 23, 2008 7:19 am

Hmmm, sounds very similar to my symptoms. I'm going to contact Objective Development officially and direct them to this thread. Thanks aikon.

Posts: 4
Joined: Wed Mar 26, 2008 12:21 am


Post by robotank » Wed Mar 26, 2008 12:26 am

I gave this app a whirl as well. I could see it being useful, but the overall level of annoyance was more trouble than it was worth. As to the uninstall, Little Snitch installs stuff all over your hard drive. After using the uninstall button, do a search for the remaining files. There are files and folders that you can find with the keywords snitch, obdev, and objective (Objective Development). Once you've trashed everything, it should be completely gone. (You'll need admin privileges since it installs all sorts of stuff in your root directory.) I did a thorough search and removed everything related that I found and I'm not getting any signs that it's still around in any form.

Posts: 1
Joined: Mon Apr 07, 2008 6:37 pm

Post by bearona » Mon Apr 07, 2008 6:42 pm

Has anybody figured this out yet? I used the uninstall option, and did a search for left over files - half of my network apps still don't work. It really makes me mad that there was no mention of 'demo' or anything like that, so I install the program and only then am I confronted with a registration thing. So I uninstall and it messes up all my network drivers. Shouldn't a software company have an obligation to provide a proper uninstall? Or at least a guide of what drivers to restore to get back to normal.

I just went through this same thing with an NTFS driver that when uninstalled disabled all ability to mount drives on my mac. It took me hours to figure out which driver files to restore.

Posts: 1
Joined: Wed May 28, 2008 1:11 am

Post by nurflugel » Wed May 28, 2008 1:25 am

The same inability of some applications to connect to the internet is now my problem as well, following install and removal of LS 2.0.2.

Apps affected are: Safari, Shiira, Fetch, and the OS 10.4.11 Software Update. And there may be others, but these I use often enough that it's difficult to work without them.

I thought that perhaps installing LS 2.0.3 would straighten things out, but it has not. Uninstalling 2.0.3 has not solved the problem, but it has not made it worse, either.

If I can't solve my problems via some tweak to the Little Snitch preferences, is there any (hopefully simple) workaround which can reconnect these apps with the internet?

Many thanks for any suggestions!

Post Reply