update to 4.1.1 = problems

General discussions about Little Snitch
Radek
Posts: 3
Joined: Wed Jul 04, 2018 1:23 pm

update to 4.1.1 = problems

Postby Radek » Wed Jul 04, 2018 2:07 pm

Hi,
I just spend two hours to install Little snitch 4, so I would like write my experience.
I had 3.8.x, so I downloaded 4.1.1 from site and not expecting any problems I install it, after reboot was all my network blocked, fans are running on high speed. Little snitch configuration app could not load either. In Activity monitor were all Little Snitch processes red. So after some attempts to do something I uninstall Little snitch and restarted macbook. After that everything worked, so I thought - ok lets try nightly build, it has to be good. Nope, after install and another restart I was in same place like before, so I uninstall it and restarted again. Then I wanted to try 4.0, maybe it will work. But could not find it, so I dowloaded 3.8. Then I remembered that when you uninstall little snitch, there was small window with check box for uninstalling configuration files. So again to install little snitch 4.1.1, reboot, uninstall (this time I checked this checkbox), reboot and then I installed 4.1.1, reboot. An then it finally worked.
I definitely didn't expect that this simple installation of version 4, which was released last year, will take me two hours. I expected that by this time most of bugs will be corrected and everything will be smooth.
Please put there some check that if Little snitch can't load configuration files, it ignores them or something similar. It will save time to quite a few users. Specially after Mojave is released.

christian
Objective Development
Objective Development
Posts: 1436
Joined: Thu Nov 09, 2006 11:46 am

Re: update to 4.1.1 = problems

Postby christian » Thu Jul 05, 2018 3:14 pm

We have a change in 4.1 which does not work well with rule sets containing more than, say, 10.000 rules. We are working on this, but it's not so easy to fix because it's mostly a bug in the frameworks. If your old rule set contained "too many" rules, 4.1 will take *quite a while* until the rules are distributed to all components. And if this while is longer than 2 minutes, the components will crash due to a timeout.

Sorry for this issue. We are aware of the problem and are working on a fix, but we either have to re-write some system functionality or re-write some code of our's which relies on the system functionality that is broken.

Radek
Posts: 3
Joined: Wed Jul 04, 2018 1:23 pm

Re: update to 4.1.1 = problems

Postby Radek » Sat Jul 14, 2018 8:39 pm

Hi,
that was not problem, I had just few hundred rules. I don't use any outside rule lists and even sometimes delete duplicate rules. It had to be something else.

christian
Objective Development
Objective Development
Posts: 1436
Joined: Thu Nov 09, 2006 11:46 am

Re: update to 4.1.1 = problems

Postby christian » Tue Jul 17, 2018 11:22 am

Version 4.1 had a bug which caused LS to check code signatures of all apps after the upgrade from 3.x or 4.0 to 4.1. This should have been fixed in 4.1.1. If you still have the problem with the current version (4.1.2), please make a spindump while it's hanging and mail it to us in support.

You can make a spindump in a Terminal window by typing

sudo spindump

You'll need an admin password for this command.

Radek
Posts: 3
Joined: Wed Jul 04, 2018 1:23 pm

Re: update to 4.1.1 = problems

Postby Radek » Wed Jul 18, 2018 11:49 pm

Luckily my only problem were configuration files from v3.8, which blocked new version of Little snitch and internet on computer. Once I deleted them, everything was working again. But I just wanted to make point that I never had more then few hundreds rules, so there should be also some other problem then what happen if you have 10.000 rules.

christian
Objective Development
Objective Development
Posts: 1436
Joined: Thu Nov 09, 2006 11:46 am

Re: update to 4.1.1 = problems

Postby christian » Thu Jul 19, 2018 8:41 pm

I know of one bug which caused this with only a hand full of rules, but that had been fixed in 4.1.1.

If anybody experiences such a hang, please make a spindump or at least a sample of the hanging process(es). We are happy to fix these issues if we can get enough information to track them down!


Return to “Little Snitch General”

Who is online

Users browsing this forum: No registered users and 6 guests