codesignature problem

General discussions about Little Snitch
Posts: 2
Joined: Thu Jun 14, 2018 2:46 pm

Re: codesignature problem

Postby » Thu Jun 14, 2018 3:10 pm

I have the same issue:


Posts: 3
Joined: Wed Jun 13, 2018 7:57 pm

Re: codesignature problem

Postby flynnoeh » Thu Jun 14, 2018 5:42 pm

user425890uhh wrote:
esseti wrote:
RockGrumbler wrote:I have experienced this bug as well. In the initial warning I choose to ignore and nothing happens. I found a work around by using the link at the top of the dialogue window that exposes the rule. This brings up the rule in the configuration app. Then I chose to edit the rule, change nothing, and hit OK. After this I am prompted with a question to ignore code signatures. When I agree at this point, it seems to take effect and the problem is resolved, or at least the code signature is ignored. I'm on OS X 10.13 and using a Cisco VPN client.

this workaround actually works.

- edit the rules and do nothing
- edit the rules and uncheck " code signature checking"
- disable the bloking rule

at least now something works, let's see how long it last

The check box and text to disable code signature checking for my AnyConnect rules is grayed out. I'm unable to disable code signature checking for those rules. :(

Same here.

Posts: 1
Joined: Sat Jun 16, 2018 8:41 pm

Re: codesignature problem

Postby dwrubel » Sat Jun 16, 2018 8:43 pm

I had a similar problem with my Citrix client after the update. Deleting the rule and recreating it solved the problem.


Posts: 4
Joined: Thu Oct 05, 2017 12:02 am

Re: codesignature problem

Postby bluloo » Tue Jun 19, 2018 5:32 pm

FYI, installation of the most recent nightly 4.1.1 (5169) fixed the code signature and crash issue for me - at least so far.

Posts: 1
Joined: Wed Jun 20, 2018 6:55 pm

Re: codesignature problem

Postby tthomas » Wed Jun 20, 2018 7:08 pm

I also had this problem with Cisco AnyConnect Client v. 4.5.04029, Little Snitch 4.1 5167, and macOS 10.13.6 Beta (17G47b). Specifically, the component vpnagentd had all outgoing connections denied, because "The code signature is unacceptable. The certificate used for signing is not trusted." I edited the rule, changed it to allow any outgoing connection, and that fixed the problem--I didn't experience the problem others have where that setting was not honored.

I remember now that I did delete the rule first, and it was created again automatically, and then I edited it.

Return to “Little Snitch General”

Who is online

Users browsing this forum: Google [Bot] and 8 guests