How to troubleshoot generic icons in LaunchBar?

General discussions about LaunchBar
bmike
Posts: 4
Joined: Tue Aug 26, 2014 10:42 pm

How to troubleshoot generic icons in LaunchBar?

Postby bmike » Fri May 04, 2018 4:23 pm

I have two Mac (one 10.12.6 and the other 10.13.x) where Launchbar is losing the icons.

So if I use command tab to switch apps in Finder - all running apps show the correct icons.
If I use control-space several times to activate launcher (control space is my shortcut for the tool) - some of the icons are replaced with a generic icon. Not all the icons are generic and when I cycle through them - some draw properly when I select them and go back to generic. Some just don't show the correct icon at all.

Image

Is there a way to rebuild or debug this? It's not functionally bad, but it's very disconcerting and I'm pretty visual so I switch to the app more on the icon than the text.

bmike
Posts: 4
Joined: Tue Aug 26, 2014 10:42 pm

Re: How to troubleshoot generic icons in LaunchBar?

Postby bmike » Fri May 04, 2018 8:06 pm

Well - It turns out LaunchBar was reporting the true status and after using both machines for a bit longer, the rest of Finder now sees these app icons as generic.

I don't know why this happened and I don't have duplicate open with entries which usually prompts an

Code: Select all

lsregister -kill -seed


The full path to lsregister is

Code: Select all

  /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -seed


See https://apple.stackexchange.com/q/324406/5472 for details if I find a root cause of the issue since I'm not sure if this just recovers from the problem or somehow the Macs we have LaunchBar on just all decided to need a launch services rebuild one day apart this year.


Return to “LaunchBar General”

Who is online

Users browsing this forum: No registered users and 1 guest