USB Hub

General discussions about V-USB, our firmware-only implementation of a low speed USB device on Atmel's AVR microcontrollers
Olovskos

USB Hub

Postby Olovskos » Mon May 11, 2015 10:49 pm

Hello,
I`m working on a Midi Interface but I have Problems connecting the Atmega to a USB Hub. It is working perfectly without a Hub. But when I put a Hub between the Device and the PC it is not showing up.... I`ve tried 4 Hubs.

Is there something I have to take care of?

Thanks in advance

blargg
Rank 3
Rank 3
Posts: 102
Joined: Thu Nov 14, 2013 10:01 pm

Re: USB Hub

Postby blargg » Tue May 12, 2015 3:42 am

Hubs can be more picky about timing. Are you using a clock crystal for the Atmega?

Olovskos

Re: USB Hub

Postby Olovskos » Tue May 12, 2015 4:26 pm

Yes, I`m using a 16 Mhz Quarzoszillator (German notation, I don`t know the english ^^) like this http://upload.wikimedia.org/wikipedia/d ... llator.jpg

First I thought it is a Win 8.1 problem but the device doesn`t appear under Linux, too.

blargg
Rank 3
Rank 3
Posts: 102
Joined: Thu Nov 14, 2013 10:01 pm

Re: USB Hub

Postby blargg » Thu May 14, 2015 6:50 am

Oh, I wonder whether it's the level-shifting zener diodes etc. Hub might be more picky about that too. Have you tried a minimal USB program on the Atmega in case there's some bug in the Midi adapter code? I think there's one that acts like a phantom key press that wouldn't need any external hardware.

Olovskos

Re: USB Hub

Postby Olovskos » Thu May 14, 2015 12:53 pm

Yes I think it is something about my wiring...

I use a bi- directional level shifter and thats the problem maybe.

I tried some examples from the V-USB download and they all act like this. Today is holiday so I think I go and buy some diodes tomorrow and try again.

I will post the results here

Olovskos

Re: USB Hub

Postby Olovskos » Sat May 16, 2015 12:21 am

UPDATE

Zener Diodes are working like a charm with hubs :D

blargg
Rank 3
Rank 3
Posts: 102
Joined: Thu Nov 14, 2013 10:01 pm

Re: USB Hub

Postby blargg » Mon May 18, 2015 8:47 am

Thanks for updating us. Interesting how you got away with it on the PC but not the hubs. Another piece of evidence of hubs being more picky, and one more reason for my personal avoidance of hubs.

BobbyJackson
Posts: 1
Joined: Wed May 20, 2015 9:19 pm

V USB Question

Postby BobbyJackson » Wed May 20, 2015 9:26 pm

Hello, Just new to this interface.

Please can someone tell me how can I buy the V USB PowerSwitch provides 8 bits of parallel output?

I am working on a project I in great need of this item

blargg
Rank 3
Rank 3
Posts: 102
Joined: Thu Nov 14, 2013 10:01 pm

Re: USB Hub

Postby blargg » Thu May 21, 2015 10:59 am

Go back to the topic list and click New Topic and ask the question there. This will keep is from being mixed with this one.


Return to “V-USB”

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron