WebYep & RomanCart - button code problem

General discussions about WebYep
Post Reply
stevep
Posts: 1
Joined: Thu Mar 10, 2011 10:16 am

WebYep & RomanCart - button code problem

Post by stevep » Thu Mar 10, 2011 10:36 am

This is a shot in the dark, but has anybody else used WebYep to update a website using the RomanCart shop system?

I have set up a website for the shop owner, and included a WebYep Loop on the shop pages. Within the Loop there are several items that make up a product, which the shop owner can edit in turn - a heading, some description text, a photo, and finally the "Add to Basket" button. The button is set up as Rich Text, and we are using TinyMCE as the editor, going into HTML mode and copy & pasting the button code in from the RomanCart page.

The good news is, it all works perfectly for me when I test it on my PC.

When the shop owner does it from her PC, something very odd happens. Everything is OK until they edit the code for the button. They click on the icon to edit the button, which opens up the TinyMCE editor window. Then they click on HTML, which opens the HTML Editor window. Now they go their RomanCart session, select the product they are adding, and click on "Show Me The Code". They copy and paste something which looks a bit like this -

<form action="http://www.romancart.com/cart.asp" method="post">
<input name="storeid" value="xxxxx" type="hidden" />
<input name="itemcode" value="12345" type="hidden" />
<input value="Add to basket" type="submit" />
</form>

With that code in the HTML editor window, they click on Update, which takes them back to the TinyMCE window - and the button which appears is NOT "add to basket" but says "Submit Query". When we click on HTML again to see the code, it has changed to

<form action="http://www.romancart.com/cart.asp" method="post"><input name="storeid" type="hidden" /><input name="itemcode" type="hidden" /><input type="submit" /></form>

Essentially, the value parameters have gone, so the button is appearing as a default Submit Query button, and this change seems to happen as we click on the Update button in TinyMCE.

As I said, it all works perfectly on another PC.

Anybody got any idea what might be causing this?

marcus
Objective Development
Objective Development
Posts: 170
Joined: Tue Nov 30, 2010 1:25 pm

Re: WebYep & RomanCart - button code problem

Post by marcus » Fri Mar 25, 2011 2:57 pm

Hmm... sounds weird and will also be hard to reproduce. Which browsers and operating systems do you and your customer use?

Post Reply