Warning on - new install

General discussions about WebYep
Post Reply
peglomaniac
Posts: 7
Joined: Sun Oct 17, 2010 6:59 pm

Warning on - new install

Post by peglomaniac » Sun Oct 17, 2010 9:23 pm

Hello

I have manually installed WebYep and my page was showing up blank until I enabled debugging.. now I am getting this error:

Warning: array_keys() [function.array-keys]: The first argument should be an array in /usr/www/users/pegleg/eliminators/webyep-system/program/lib/WYApplication.php on line 391

Warning: Invalid argument supplied for foreach() in /usr/www/users/pegleg/eliminators/webyep-system/program/lib/WYApplication.php on line 391



I followed all the steps in the install guide, including giving permissions "777" (applying changes recursively, as that was the only option) to the webyep-system folder on the server, and adding timymce to the opt folder. I did not modify permissions of the tinymce folder.

I also added the opening bit of code to the webyep page. It page is at http://www.eliminators.ca/swap_meet.php so if someone could tell me where I went wrong and how to get rid of that error, I'd appreciate it.

peg

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: Warning on - new install

Post by manfred » Wed Oct 20, 2010 4:50 pm

Dear peg,

Please note this is a warning and no error. So this shouldn't be the reason.

Unfortunately your provided link isn't reachable.

peglomaniac
Posts: 7
Joined: Sun Oct 17, 2010 6:59 pm

Re: Warning on - new install

Post by peglomaniac » Thu Oct 21, 2010 10:06 am

Oh, I hate it when I do that.. I am sorry.. I changed the page entirely as a troubleshooting measure.

It is now at http://www.eliminators.ca/swap_shop.php

Thanks Manfred.

peg

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: Warning on - new install

Post by manfred » Wed Oct 27, 2010 5:46 pm

Peg,

As I mentioned before, this is a warning only. We will remove this messages in one of the upcoming releases.

Please note: Display warning and error messages within the webpage is always a security problem. So please disable it.

peglomaniac
Posts: 7
Joined: Sun Oct 17, 2010 6:59 pm

Re: Warning on - new install

Post by peglomaniac » Wed Oct 27, 2010 6:58 pm

I am sorry - I do not mean to be troublesome.

I have been looking all over for how to disable the display warnings, but I can't recall how I enabled that.

Please advise. Meantime, I'll keep looking.

I did not see a warning that it was a security issue when I enabled it...

peg

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: Warning on - new install

Post by manfred » Thu Oct 28, 2010 6:52 pm

Please take a look in your config-inc.php file.
Set the variable $webyep_bDebug to false.

In addition to that, please disable the PHP option »display_errors«.

peglomaniac
Posts: 7
Joined: Sun Oct 17, 2010 6:59 pm

Re: Warning on - new install

Post by peglomaniac » Fri Oct 29, 2010 5:59 am

Thank you manfred - I have disabled the display warnings, as well as the display errors, and my problem is solved. Thank you kindly.

peg

Post Reply