first test on local server

General discussions about WebYep
Post Reply
atelier
Posts: 4
Joined: Tue Dec 15, 2009 4:41 pm

first test on local server

Post by atelier » Tue Dec 15, 2009 4:52 pm

Hi

I'm new here, so apologies if my question has been asked before. (I searced for 'local' did not find anything)

Situation.
I test my sites locally, in MacOSX with a XAMPP build.
The testsite is reachable locally at http: // www . localhost/~my-username/testsite/index.php
The WebYep folder is /Home/Sites-Folder/testsite/

As expected (?) WebYep complains that it cannot see it's own folder. I think WebYep expects it's location at the highest level of the server, and that is not the case here.

How, and where do I set the right path?

Thanks!

atelier
Posts: 4
Joined: Tue Dec 15, 2009 4:41 pm

Re: first test on local server

Post by atelier » Thu Dec 17, 2009 12:08 pm

Hi

I do hope someone has a solution for me. I want to test my site locally, but WebYep does not work. I think it has to do with some setting, but I cannot find the location where i should do that.

Thank you.

atelier
Posts: 4
Joined: Tue Dec 15, 2009 4:41 pm

Re: first test on local server

Post by atelier » Thu Dec 17, 2009 12:22 pm

Hm. Got it working.
But now I have an error

Code: Select all

Deprecated: Function set_magic_quotes_runtime() is deprecated in /Users/myname/Sites/test/webyep-system/program/webyep.php on line 7:


And when i login I get:

Code: Select all

Deprecated: Assigning the return value of new by reference is deprecated in /Users/myname/Sites/test/webyep-system/program/logon.php on line 21

Deprecated: Assigning the return value of new by reference is deprecated in /Users/myname/Sites/test/webyep-system/program/logon.php on line 23

Deprecated: Assigning the return value of new by reference is deprecated in /Users/myname/Sites/test/webyep-system/program/logon.php on line 26

Deprecated: Assigning the return value of new by reference is deprecated in /Users/myname/Sites/test/webyep-system/program/logon.php on line 27

Deprecated: Function set_magic_quotes_runtime() is deprecated in /Users/myname/Sites/test/webyep-system/program/webyep.php on line 7


any idea? :(

Max
Rank 4
Rank 4
Posts: 176
Joined: Wed Nov 08, 2006 10:39 pm
Location: UK
Contact:

Re: first test on local server

Post by Max » Fri Dec 18, 2009 10:29 pm

Hi atelier
try using MAMP
its seems to work better than XAMPP
you can down load it from here
http://www.mamp.info/en/index.html

just download the free version and
here is a quick instructions on how to use it:



Quick instruction


Below is some simple instructions for testing webyep on your mac this is part of the new manual which I hope to finish soon
it explains how to install a fully functioning server on your mac and how to test webyep. I use this method when I am building webyep site because I do not need to be connected to the internet plus I can test and see what the site will look like straight away.

Instructions if you need to start to build your site and test it on your mac

if you do want run webyep pages on the mac you will need to download the free MAMP software, you can get it here: http://www.mamp.info/en/index.php
just download the normal application you don't need the pro version
once you have downloaded the application and followed the install instructions you just need to
 launch the application you will see a window pop


ok now you can place your whole site in the special folder called htdocs within the MAMP folder which was installed in your applications folder
   

Now go back to the MAMP activation window and click on open start page if it already hasn't been launched .


Now in the browser http address remove the MAMP/?language=English and hit return it should then launch the index page of your site.

johannes
Objective Development
Objective Development
Posts: 815
Joined: Fri Nov 10, 2006 4:39 pm
Contact:

Re: first test on local server

Post by johannes » Sat Dec 19, 2009 7:44 pm

These are not error messages, but low priority warnings.

But neither warnings nor error messages should appear inside the page. WebYep tries to set the error and warning level when in normal (not debug) mode so that no PHP messages get displayed into the page.

In your installation WebYep does not seem to be able to do that - I unfortunately cannot say why.

But you could try to set the error reporting mode directly for PHP - look for the php.ini for that XAMP installation and set:

Code: Select all

error_reporting = E_COMPILE_ERROR|E_ERROR|E_CORE_ERROR
display_errors = Off

atelier
Posts: 4
Joined: Tue Dec 15, 2009 4:41 pm

Re: first test on local server

Post by atelier » Mon Dec 21, 2009 7:59 pm

Hi

Thanks for these responses.
I have the WebYep app now running on the server of my ISP. Did not try it locally any further.
WebYep looks interesting, certainly for a small site.

For the local server:
I skipped XAMP, and installed MAMP now. Much better (I'm also testing the trial of Expression Engine, which runs good on it.)

Thanks again.

Post Reply