LaunchBar 6 no longer pulls up my Applications

General discussions about LaunchBar
Post Reply
GEJII67
Posts: 2
Joined: Wed Dec 17, 2014 8:31 pm

LaunchBar 6 no longer pulls up my Applications

Post by GEJII67 » Wed Dec 17, 2014 8:43 pm

Ever since upgrading to LaunchBar 6 on a Mac with Yosemite, LaunchBar 6 will only pull up actions related to an application I want it to launch instead of the application. I don't even see the app in the list it pulls up.

For example, I hit my shortcut to bring LaunchBar up and then type "om" so I can launch Omnifocus and it only brings up the Omnifocus Services folder and Omnifocus 2: Send to Inbox. I don't have a choice to launch Omnifocus. Same with all of my apps. Please let me know if there is a setting that needs to be changed. Thanks!

kastorff
Rank 1
Rank 1
Posts: 37
Joined: Fri Dec 14, 2007 5:58 pm

Re: LaunchBar 6 no longer pulls up my Applications

Post by kastorff » Thu Dec 18, 2014 4:45 am

Check the Index to see if LB is still indexing your Applications. Show the index from the LB menu, then right-click on Applications. If you see "Enable" as an option, select it. Otherwise, try a manual "Update" from the same menu.

GEJII67
Posts: 2
Joined: Wed Dec 17, 2014 8:31 pm

Re: LaunchBar 6 no longer pulls up my Applications

Post by GEJII67 » Fri Dec 19, 2014 1:49 am

Thanks for the great tip! It fixed my problem.

I'm not sure how that setting got turned off, but I'm glad there was an easy fix.

Jaharmi
Rank 2
Rank 2
Posts: 48
Joined: Sat Dec 02, 2006 6:50 am

Re: LaunchBar 6 no longer pulls up my Applications

Post by Jaharmi » Thu Feb 19, 2015 2:27 am

I’m having the same problem. I’m not sure when it started, Some of my applications are indexed, others — newer apps that have been added to /Applications recently — are not.

Indexing for applications is enabled. It is set to use the OS X LaunchServices database and search in /Applications and /System/Library/CoreServices.

I’ve tried manually updating multiple times. I’ve also tried to disable indexing and then re-enable it. I’ve rebuilt the the LaunchServices database (/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user) and the Spotlight index (mdutil -E /).

I can access missing applications via a sub-search of the /Applications folder in LB.

I’m using LaunchBar 6.1.6 on OS X Yosemite v10.10.2.

Jaharmi
Rank 2
Rank 2
Posts: 48
Joined: Sat Dec 02, 2006 6:50 am

Re: LaunchBar 6 no longer pulls up my Applications

Post by Jaharmi » Thu Feb 19, 2015 2:46 am

My Applications index issue appears to be fixed. I had added several new applications to my system using an Action in LaunchBar. Unbeknownst to me, that placed the apps in my ~/Applications folder, which was not indexed. (While uncommon to have one, it might make sense to index it by default if it exists.)

Once I moved these applications to /Applications from ~/Applications, they were indexed and appeared in LaunchBar immediately. Problem solved.

Update: I deleted the Applications index and re-added the System > Applications index. That added my ~/Applications folder (and ~/Library/Printers, which seems odd) to the locations searched.

Post Reply