Indexing every 2 seconds. How can I stop this?

General discussions about LaunchBar
Post Reply
RPN
Posts: 1
Joined: Thu Jul 17, 2014 1:27 pm

Indexing every 2 seconds. How can I stop this?

Post by RPN » Thu Jul 17, 2014 2:01 pm

I have done the opt-cmd-p to stop indexing, have gone into LB Index, unchecked almost every application Index, eliminating all folders in Options except core services. The near constant indexing continues. I click "?" in the Index window and let to page announcing, "The selected topic is currently unavailable. The topic you were trying to view could not be found."

In Support/LB/FAQs/General Questions/Where is the documentation I get the message "An updated version for LaunchBar 6 is already on its way." What does that mean?

Really LB, I am trying, but help me out here. I find myself closing LB and going back to Alfred 2.

I just want the bloody near-constant Indexing to stop!

parneix
Rank 1
Rank 1
Posts: 23
Joined: Mon Jan 10, 2011 3:17 am

Re: Indexing every 2 seconds. How can I stop this?

Post by parneix » Sat Jul 19, 2014 4:02 pm

Are you using LB6? Are you able to monitor the activity of your CPU? I noticed a similar pattern where LB6 is constantly launching into burst of indexing, eating a lot of CPU resources in the process. When I check CPU process, it looks like the teeth of a saw: it spikes each time LB6 launches a new indexing cycle (very short bursts).

You can check my original thread here: viewtopic.php?f=4&t=9110

This may or may not be linked to other problems reported on this forum (his memory usage, slow response time). I’d suggest you try to contact the support by email (no solution yet for me: I reverted back to LB5).

ateichman
Posts: 6
Joined: Sun Jul 20, 2014 4:24 pm

Re: Indexing every 2 seconds. How can I stop this?

Post by ateichman » Sun Jul 20, 2014 4:33 pm

I'm experiencing the same problem. I've been in touch with support and they have been moderately responsive, but not particularly helpful. What I find is that it is repeatedly indexing Scripts, Actions, Categories and Applications. In addition, the memory footprint climbs from a couple hundred MB to well over a gig in the space of a day.

Based on the info from support, try the following:

I would like to ask you to open your LaunchBar Index Window (⌥⌘I),
deactivate any suspicious indexing rules like external volumes
and
check if this makes any difference regarding CPU usage.

Generally I would like to recommend you to keep you index as
lightweight as possible and sort out such items you do not search
via abbreviation.
For example having the Search Scope in your Home~ directory set to
'Search All Subfolders' might not be of any benefit, since it
will
probably index lots of files and folders you do not need in your
index – like all files in your ~/Library/ folder.
You could add such folders you don't need to be indexed to the
'Exclude Items' of your home index rule options.

Maybe you can even identify the location which triggers the
frequent
updates. One thing you could do to track this issue would be to
start LB in Debug Mode.
To do so, you would have to quit LB, and then open it with the ⌥
option key pressed.
Please check:
- Launch Console application
- Log file indexing progress


Filtering the system log files with the word "indexing" will give you an idea of what's going on. Please post (condensed!) results, so we can compare.

parneix
Rank 1
Rank 1
Posts: 23
Joined: Mon Jan 10, 2011 3:17 am

Re: Indexing every 2 seconds. How can I stop this?

Post by parneix » Sun Jul 20, 2014 4:58 pm

Hi,

I’ve also been in contact with support and I would also describe it as being “moderately responsive”. I received the same suggestions you did. My problem with deactivating “suspicious indexing rules” is two-fold. First, it’s a rather vague criterion. I’ve deactivated all external drives and made sure I don’t use “search all subfolders”, to no avail. I was also asked to deactivate ALL index rules to see if the problem persists: the problem was gone, but LB6 was consequently render unusable. Second, those index rules work perfectly fine under LB5 (which I’m currently using). There is absolutely no problem with the rules I’m using in LB5. It’s a bit disconcerting to have an update that asks to scale down the way I use LB.

I did also run LB6 in debug mode (with various options checked). I ran tests for them a couple of times. Last time, I’ve noticed from the logs that LB6 seems to be stuck in a loop of indexing. I have sent those results (at their request) 4 days ago and I’m still awaiting for an answer. See sample from log below:

indexing Home ~...
2014-07-16 10:43:49.724 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9858 seconds)
2014-07-16 10:43:49.742 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:43:49.800 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0577 seconds)
2014-07-16 10:43:58.595 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:43:59.570 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9752 seconds)
2014-07-16 10:43:59.577 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:43:59.631 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0537 seconds)
2014-07-16 10:44:08.345 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:44:09.328 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9838 seconds)
2014-07-16 10:44:09.335 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:44:09.388 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0528 seconds)
2014-07-16 10:44:18.181 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:44:19.158 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9776 seconds)
2014-07-16 10:44:19.166 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:44:19.215 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0493 seconds)
2014-07-16 10:44:27.955 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:44:28.925 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9695 seconds)
2014-07-16 10:44:28.932 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:44:28.985 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0533 seconds)
2014-07-16 10:44:37.651 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:44:38.623 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9728 seconds)
2014-07-16 10:44:38.631 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:44:38.680 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0493 seconds)
2014-07-16 10:44:47.378 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:44:48.342 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9647 seconds)
2014-07-16 10:44:48.350 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:44:48.402 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0525 seconds)
2014-07-16 10:44:57.024 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:44:57.998 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9740 seconds)
2014-07-16 10:44:58.005 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:44:58.060 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0545 seconds)
2014-07-16 10:45:06.762 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:45:07.729 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9673 seconds)
2014-07-16 10:45:07.736 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:45:07.790 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0538 seconds)
2014-07-16 10:45:16.434 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:45:17.434 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 1.0008 seconds)
2014-07-16 10:45:17.441 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:45:17.492 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0510 seconds)
2014-07-16 10:45:26.440 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:45:27.429 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9896 seconds)
2014-07-16 10:45:27.436 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:45:27.490 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0537 seconds)
2014-07-16 10:45:36.336 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:45:37.309 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9731 seconds)
2014-07-16 10:45:37.316 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:45:37.376 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0599 seconds)
2014-07-16 10:45:46.063 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:45:47.171 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 1.1080 seconds)
2014-07-16 10:45:47.189 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:45:47.253 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0635 seconds)
2014-07-16 10:45:57.138 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:45:58.123 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9850 seconds)
2014-07-16 10:45:58.130 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:45:58.187 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0567 seconds)
2014-07-16 10:46:06.989 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:46:07.975 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9869 seconds)
2014-07-16 10:46:07.983 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:46:08.036 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0533 seconds)
2014-07-16 10:46:16.855 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:46:17.855 AM LaunchBar[47815] indexing Home ~ completed (2957 items, 0.9992 seconds)
2014-07-16 10:46:17.866 AM LaunchBar[47815] indexing Categories...
2014-07-16 10:46:17.930 AM LaunchBar[47815] indexing Categories completed (233 items, 0.0631 seconds)
2014-07-16 10:46:26.845 AM LaunchBar[47815] indexing Home ~...
2014-07-16 10:46:28.021 AM LaunchBar[47815] indexing Home ~ completed (2957

ateichman
Posts: 6
Joined: Sun Jul 20, 2014 4:24 pm

Re: Indexing every 2 seconds. How can I stop this?

Post by ateichman » Mon Jul 21, 2014 1:58 am

I have similar logs, and that is pretty much what I experienced in the way of support: ever-lengthening periods between replies, and no suggestions that actually produce results.

So, I finally gave up and did what they probably should have told me to do in the first place - uninstall and reinstall. Uninstall instructions are here. Do get rid of the caches, and prefs. So far, so good. Memory footprint is steady where it was when I first launched it several hours ago, and CPU usage is steady and minimal. I'll update once it has had a chance to run for a day or so.

parneix
Rank 1
Rank 1
Posts: 23
Joined: Mon Jan 10, 2011 3:17 am

Re: Indexing every 2 seconds. How can I stop this?

Post by parneix » Mon Jul 21, 2014 2:10 am

Thanks for the feedback, it is appreciated. I think you forgot to put the HTML link for the instructions.

Am I correct to assume that you did a fresh install, dumping all your preferences, and therefor starting with LB as if you had never used it before? You re-customized your index, etc.?

ateichman
Posts: 6
Joined: Sun Jul 20, 2014 4:24 pm

Re: Indexing every 2 seconds. How can I stop this?

Post by ateichman » Mon Jul 21, 2014 2:24 am

Oops. Here is the link: http://www.obdev.at/products/launchbar5/faq.html

UPDATE:

The link above is defunct. Here is what it led to:

How to uninstall LB...

Short answer:
    Move it to the Trash.
Long answer:
    If LaunchBar is currently running, quit it.
    Delete the LaunchBar application file (wherever you’ve installed it, usually in your Applications folder).
    Optionally, delete the preferences file, which is located at
    ~/Library/Preferences/at.obdev.LaunchBar.plist (the ~ tilde sign refers to your home folder)
    Optionally, delete LaunchBar’s application support folder (containing the configuration and other LaunchBar related files). This folder is located at ~/Library/Application Support/LaunchBar
    Optionally, delete LaunchBar’s cache folder which is located at ~/Library/Caches/LaunchBar
    If you have added LaunchBar to your “Login Items” in System Preferences in order to get it started automatically at login, you may wish to remove this entry as well.


[END OF UPDATE]

Yes, that is what I did. However, I took a screenshot of my index first, and a couple of the pref panes. It didn't take long to restore things.
Last edited by ateichman on Fri Feb 06, 2015 4:25 am, edited 1 time in total.

parneix
Rank 1
Rank 1
Posts: 23
Joined: Mon Jan 10, 2011 3:17 am

Re: Indexing every 2 seconds. How can I stop this?

Post by parneix » Mon Jul 21, 2014 4:59 pm

Did the same thing on my side: uninstalled everything, emptied the trash (but did not restart), downloaded the nightly build (6.1), reinstalled, customized it the way I like it, and its been running every since without the problem I had before. I added an indexing rule for my main data folder with a rule to search 3 subfolder levels. It didn’t even flinch. No "saw teeth" pattern, no crazy CPU consumption, not “burst indexing”.

I wish support had suggested a fresh install in the first place: back-and-forth testing has been going on with them since early June. And I’m still waiting for feedbacks from the latest tests they asked me to run. Hopefully, others will find this thread useful.

ateichman
Posts: 6
Joined: Sun Jul 20, 2014 4:24 pm

Re: Indexing every 2 seconds. How can I stop this?

Post by ateichman » Mon Jul 21, 2014 5:25 pm

I can report similar results after leaving it running for a day now. No problems.

I have to say that reinstalling seemed to me like a pretty self-evident remedy in the first place, once it was evident that the update had caused a previously stable app to go wacky. Corrupted prefs or caches can make things behave unpredictably. The only reason I didn't go that route immediately was because I wanted to help them track down the issue. If I "erased" the issue, then that wouldn't help anyone else.

I just got tired of waiting for support to clue into the most obvious fix.

Post Reply