Page 1 of 2

Does LB6 launch Safari in background on Mavericks?

Posted: Wed Jun 25, 2014 3:13 pm
by vcaston
LB6.0.1, Mavericks 10.9.3

Safari is *not* my default browser, not launched on login, and I rarely use it. But I find it is open and running in the background, with only LaunchBar running and not when it's not.

Is this just something to live with? Or is there a setting I should be aware of?

Victor

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Wed Jun 25, 2014 5:18 pm
by iRounak
interesting, i m also trying to find out what makes safari open at startup. will try restarting without lb and see the result

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Thu Jun 26, 2014 6:04 am
by iRounak
LB does not seem to be the reason for this problem

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Mon Jun 30, 2014 5:15 pm
by Cabinda
Hello,

I registered to this forum for the first time, because I am seeing the same problem. For me, it's a bug and it's clearly caused by LaunchBar (I tested on two different computers). Safari is not my default browser, and I don't use it, but I see it launched from time to time when LaunchBar is running. The Safari launch seems to occur on disk ejection, be it the ejection of a physical disk or of a virtual disk (DMG container). It doesn't happen systematically on every ejection, but it happens occasionally. My guess is that LaunchBar's indexer is at fault.

I am using LaunchBar 6.0.1 and OS 10.9.3.

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Tue Jul 01, 2014 6:01 am
by Allsop
I am also having this problem.

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Thu Jul 10, 2014 5:18 pm
by vcaston
It occurs for me without any disk ejection. I have repeatedly tested leaving nothing open overnight and leaving only LB open, and consistently Safari is open in the morning if LB is, and not otherwise.

Victor

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Fri Jul 25, 2014 11:19 pm
by nathanael
this probably has to do with a bug in LaunchBar triggered by a custom lbaction in your setup.
During the start of LB6 (but not if i start indexing by hand) each application used by an applescript in a lbaction gets started. A simple lbaction with an "on run" handler containing "tell application "DEVONthink Pro..." triggers the start of DEVONthink shortly after I start LaunchBar. Note: LBAssociatedApplication is com.apple.Safari in that case, not DEVONthink. the "on run" handler doesn't get executed at that point btw (a "display dialog" is not shown).

This problem happens with all applications, an lbaction to switch my Skype status for example triggers the launch of Skype. I'm on 6.1 nightly.

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Sun Jul 27, 2014 8:49 pm
by Roller
I was having the same problem but it didn't start when Launchbar 6 was installed but started sometime later. I'm not saying it's the "Action" that I had installed that was causing it but once I removed it this problem stopped for me. It was the "Safari Tab" Action that I uninstalled.

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Mon Jul 28, 2014 3:24 pm
by manfred
See my answer at this thread: lbaction causes launch of 'referenced' applications
Looks like LaunchBar Actions might cause this issue. We are looking into it!

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Mon Jul 28, 2014 7:00 pm
by Roller
Thanks Manfred. :-)

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Tue Aug 23, 2016 11:17 am
by mrcmrc
Hi,
just asking if someone have found a solution to this problem, currently on two different computers with Safari launch problem continues to be present.

Note: my version of LaunchBar is 6.7.2 (6136) on OSX El Capitan 10.11.6.

Thanks!
- Marco.

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Thu Sep 15, 2016 4:22 pm
by RocketJSquirrel
Same here.

I have been seeing Safari Launch spontaneously and intermittently in the background for a year or better; there is no pattern to it that I’ve been able to discern. It's occurred over several versions of Mac OS X and LaunchBar. Current versions are Mac OS X 10.11.6 and LaunchBar 6.7.2 (6136) on two machines: MacBook Pro (17-inch Mid/Late 2007, 2.4 GHz) and Mac Pro (Mid 2010).

In reference to viewtopic.php?f=4&t=9219: There are no files in ~/Library/Application Support/LaunchBar/Actions on either machine.

I inadvertently stumbled upon this thread on Google while looking for something else, but I’ve actually been looking for a solution to the problem for the year or so previously noted. Upon finding this thread I quit LaunchBar on the Mac Pro, while leaving it running on the MacBook Pro. For several days now Safari has not launched once on the Mac Pro (non-LaunchBar machine), but the problem continues on the MacBook Pro (LaunchBar is running).

Is there a workaround or a forthcoming fix?

Thanks.

UPDATE (24 September, 2016):

So, after several days of having LaunchBar disabled, I re-enabled it. It has now been enabled for several more days, and Safari has not launched unbidden even once. WTF? Who knows. After a year or so I changed nothing and the problem's gone? Cannot explain it.

Regardless, it would have been nice to receive a response from support on this. But I suppose never mind. I fixed it. I guess.

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Tue Nov 22, 2016 12:05 pm
by vcaston
Has anyone found a solution to this problem? Still happens, on all my computers, and appears to wake them up from sleep.

Only happens when LB6 is on. Nothing in the Actions folder.

Victor

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Tue Nov 22, 2016 5:51 pm
by RocketJSquirrel
I thought I had inadvertently solved the problem or that it had 'solved' itself, but I was mistaken--it continues to happen.

Since my original report I have upgraded my Mac Pro (Mid 2010) to macOS 10.12.1, while my MacBook Pro (17-inch Mid/Late 2007, 2.4 GHz) remains at Mac OS X 10.11.6. Both machines continue to run LauncBar 6.7.2.

I've watched the two machines like a hawk. I've caught Safari Launching spontaneously and then dug into the Console & system.log. I can find nothing in the logs. I cannot reproduce the problem at will by taking some particular action. I'm good at this, and it's makin' me nuts that I can't figure it out. The one thing that does not vary is that Safari Launches spontaneously / seemingly randomly when LaunchBar is running, but Safari does not Launch spontaneously when LaunchBar is not running.

As an aside, I see no evidence that anyone at Obejective Development is monitoring this thread. Since this is the only method by which paying LaunchBar customers may receive support, it sure would be nice if we received an acknowledgement, followed by a fix.

Re: Does LB6 launch Safari in background on Mavericks?

Posted: Fri Dec 09, 2016 7:52 pm
by RocketJSquirrel
I just e-mailed the following to Objective Devlopment Support:

ThunderbirdScreenSnapz001.jpg

Hopefully, we will receive a reply soon.