Page 1 of 1

Launchbar issue with Mavericks 10.9.3

Posted: Wed Jun 04, 2014 4:43 am
by curtisjackson
Since I upgraded to Mavericks 10.9.3, When I hit Command-space to cycle through my running apps and switch to a different one, one app is often missing.

For example, I tried to switch to Safari, but Safari wasn't in the list of running apps. A few minutes later I launched Pages, used Launchbar to switch to Chrome for a moment, then tried to switch back to Pages but it wasn't in the list of running apps.

At this point I checked Launchbar for updates and found I was running an older version (? 5.1.x ?), so I quit the current version, downloaded and installed the latest. But I then launched DosBox, switched to a different app, then when I tried to switch back to DosBox it wasn't there. I verified I was running the latest Launchbar (5.6.4). I quit and relaunched Launchbar. DosBox was running but still did not show in Launchbar's running app list. I went into Launchbar and manually selected Show Running Apps, and it isn't there.

I live, eat, and breathe Launchbar and this is driving me crazy! Help?