Page 1 of 1

Launchbar does not appear in every space MT. Lion

Posted: Sat Aug 04, 2012 1:04 pm
by devananda
Launchbar was not opening (or appearing), then I moved (using 4 finger swipe) to the first space and it worked fine again.

so LB will only appear if I am in the first space and it will not appear if I am in any other space. (spaces are controlled in system preferences / mission control but you can't assign an application to spaces like you could in snow leopard).

How can I make launchbar appear in every space in Mt. Lion?

I'm using LB 5.3

on a

MacBook Pro OSX 10.8
HD: 500 GB
Processor: 2 GHz Intel Core i7
Memory: 8 GB 1333 MHz DDR3

Re: Launchbar does not appear in every space MT. Lion

Posted: Mon Aug 06, 2012 9:58 pm
by urippa
The behaviour you're reporting is incorrect. I'm running the same config and hardware as you and LB is available in all Spaces/desktops, including full screens.

[Re: assigning apps to desktops, that feature is still available (except where the app you are selecting is in full screen). Easiest way to do it is to click and hold, or ctrl-click, on the app's dock icon, and select "options" "assign to" in the pop-up menu. But as far as fixing your LB experience that's not likely to be a fruitful avenue anyway]

Note that depending on how you are set up, you will have to invoke LB separately in each space/desktop; it will not stay at the front across desktops.

Action: Repair permissions, restart your Mac, download the latest LB nightly build and install, repair permissions, restart. Now that might seem like a pain, but you will know you have done everything right as far as LB is concerned, and we can more readily solve any real underlying problem.

Re: Launchbar does not appear in every space MT. Lion

Posted: Tue Aug 07, 2012 11:05 pm
by devananda
urippa wrote:The behaviour you're reporting is incorrect. I'm running the same config and hardware as you and LB is available in all Spaces/desktops, including full screens.

[Re: assigning apps to desktops, that feature is still available (except where the app you are selecting is in full screen). Easiest way to do it is to click and hold, or ctrl-click, on the app's dock icon, and select "options" "assign to" in the pop-up menu. But as far as fixing your LB experience that's not likely to be a fruitful avenue anyway]

Note that depending on how you are set up, you will have to invoke LB separately in each space/desktop; it will not stay at the front across desktops.

Action: Repair permissions, restart your Mac, download the latest LB nightly build and install, repair permissions, restart. Now that might seem like a pain, but you will know you have done everything right as far as LB is concerned, and we can more readily solve any real underlying problem.


Thanks for the reply and thanks for noting that i'll have to invoke LB separately on each desktop.

I did as you suggested: I repaired the permissions, I also ran cleanup utilities on onyx but I restarted the computer several times.

I have the latest version of LB and there aren't any nightly builds on the Web site. I have 5.3 (938).

If I am in a clear desktop (previously called "space" in Snow Leopard) then LB does not appear. LB only appears in the first desktop. When I invoke LB it only appears in desktop one and it will not invoke if I am in any other desktop.

So, in the dock I right clicked and chose "options" assign to all desktops.

and now it works in all desktops.

thank you