Problems with Index of 5.2 Nightly (905)

General discussions about LaunchBar
Dazzzz
Posts: 2
Joined: Fri Dec 30, 2011 1:13 am

Problems with Index of 5.2 Nightly (905)

Post by Dazzzz » Fri Dec 30, 2011 1:21 am

Hi,

I have been using LaunchBar for years and can't be without it. Recently I have started to have Apps go missing from my index. For example I would normally type IC for iChat. LaunchBar can no longer find it. When I go to the Index page, it's no longer under Applications, yet it is still in the Applications Folder. I press Update and it still does not appear.

I have tried removing LaunchBar and all Prefs, Caches and Application Support folders and re-running it, however iChat and some other Apps still are missing. I have also repaired disk permissions to no avail.

Clearly I'm not just concerned about iChat going missing, rather there are more Apps than that and I don't know how to make sure they are discovered again.

Any suggestions please?

TomEck
Rank 2
Rank 2
Posts: 55
Joined: Mon Mar 02, 2009 10:41 am

Re: Problems with Index of 5.2 Nightly (905)

Post by TomEck » Mon Jan 02, 2012 3:32 pm

I have the same problem.

Work around: Create a new (separate) rule for indexing the application folder and disable the default rule.

Was
Rank 2
Rank 2
Posts: 70
Joined: Wed Jan 13, 2010 2:27 am

Re: Problems with Index of 5.2 Nightly (905)

Post by Was » Tue Jan 03, 2012 5:40 pm

Really wish the devs would respond quicker to things like this, both in the forums and in development. There's at least two other major bug in the stable release for Lion that have been known for quite some time.

To be honest, I can't help increasingly comparing LB with Alfred, which seems to be coming along at a breakneck pace...

Dazzzz
Posts: 2
Joined: Fri Dec 30, 2011 1:13 am

Re: Problems with Index of 5.2 Nightly (905)

Post by Dazzzz » Thu Jan 05, 2012 6:56 am

It seems to be resolved. I removed 5.2 and reinstalled 5.1.3 and after recreating a few of my shortcuts, it seems to be working again. I'll skip current 5.2 nightly build and wait for the next one.

F451
Rank 1
Rank 1
Posts: 27
Joined: Tue Nov 21, 2006 2:24 pm

Re: Problems with Index of 5.2 Nightly (905)

Post by F451 » Fri Jan 06, 2012 8:50 pm

TomEck wrote:I have the same problem.
Work around: Create a new (separate) rule for indexing the application folder and disable the default rule.

Thanks for the workaround! It's a beta so I have no expectations and realize that matters such as this arise. :D

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: Problems with Index of 5.2 Nightly (905)

Post by manfred » Thu Jan 12, 2012 5:29 pm

LaunchBar 5.2 nightly changed the way how LaunchBar is indexing applications. The nightly build is using the Spotlight Index provided by the system. Unfortunately it turned out that the Spotlight Index might become inconsistent from time to time which cause issues like the described ones.

It is not necessary to create a separate indexing rule to get rid of this issue. Disabling of »Use Spotlight index« in the application rule options should help as well.

F451
Rank 1
Rank 1
Posts: 27
Joined: Tue Nov 21, 2006 2:24 pm

Re: Problems with Index of 5.2 Nightly (905)

Post by F451 » Sun Jan 29, 2012 12:24 am

Fresh Install

What I did that led to improvement was to delete the LaunchBar app and all associated files. Then I downloaded the latest beta and install it. You'll have to have your license information available, if you want to use LaunchBar past the trial period.

sjk
Wizard
Wizard
Posts: 315
Joined: Thu Sep 13, 2007 9:46 pm
Location: Eugene
Contact:

Re: Problems with Index of 5.2 Nightly (905)

Post by sjk » Tue Apr 10, 2012 9:32 pm

Decided to finally check the forum for reports of this issue after it bit me again this morning. Glad I'm not the only one having it.

manfred wrote:Disabling of »Use Spotlight index« in the application rule options should help as well.

I've just toggled that option (thanks for mentioning it) off/on to see if it improves application indexing for future app installs/updates.

With the option enabled, presumably the workaround I've used of invoking Update Index > Applications [Command-1] whenever an app doesn't appear has always been successful because it reverts to the non-Spotlight method of index updating?

F451 wrote:What I did that led to improvement was to delete the LaunchBar app and all associated files.

I don't see how reinstalling the LB app could matter. Seems more likely something in the associated files might have been influencing indexing misbehavior, though that's only a hunch. Deleting the latter is a more drastic measure than I'd like to take, for now. I'll consider it if the issue still persists with Mountain Lion. Or, maybe just leave the Use Spotlight index option disabled. :)

sjk
Wizard
Wizard
Posts: 315
Joined: Thu Sep 13, 2007 9:46 pm
Location: Eugene
Contact:

Re: Problems with Index of 5.2 Nightly (905)

Post by sjk » Fri Apr 13, 2012 7:26 pm

Here's a bit more info about the indexing issue. While copying a new version of calibre to /Applications these console messages appeared, as did the Indexing Progress window briefly (because Automatically show and hide Indexing Progress is enabled), before the copy had finished:

Code: Select all

Apr 13 07:06:59 aura LaunchBar[317]: ODMetadataQuery returns nil-path at index 31 (name=calibre)
Apr 13 07:06:59 aura LaunchBar[317]: Invalid NSServices entry in /Applications/Evernote.app: {
       NSMessage = openSelection;
       NSPortName = Evernote;
       NSSendTypes =     (
           NSRTFDPboardType,
           NSRTFPboardType,
           NSStringPboardType
       );
   }

Afterwards, calibre wasn't in LB's index until invoking Command-1 to force reindexing.

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: Problems with Index of 5.2 Nightly (905)

Post by manfred » Wed Apr 18, 2012 11:07 am

This issue should be fixed with LaunchBar 5.2 (909).

Ganlron
Posts: 2
Joined: Wed Apr 18, 2012 1:57 pm

Re: Problems with Index of 5.2 Nightly (905)

Post by Ganlron » Wed Apr 18, 2012 1:58 pm

Wasn't having this problem with the nightly, but I am now having the exact same problem with 909 :(

Ganlron
Posts: 2
Joined: Wed Apr 18, 2012 1:57 pm

Re: Problems with Index of 5.2 Nightly (905)

Post by Ganlron » Wed Apr 18, 2012 2:11 pm

Tried deleting and reinstalling launchbar, still hangs with "Reading list of installed applications..." when viewing the indexing process :(

sjk
Wizard
Wizard
Posts: 315
Joined: Thu Sep 13, 2007 9:46 pm
Location: Eugene
Contact:

Re: Problems with Index of 5.2 Nightly (905)

Post by sjk » Wed Apr 18, 2012 6:36 pm

These console messages appeared when launching LB 5.2 (non-nightly) the first time after updating:

Code: Select all

Apr 17 15:42:05 aura LaunchBar[54029]: Invalid NSServices entry in /Applications/Evernote.app: {
       NSMessage = openSelection;
       NSPortName = Evernote;
       NSSendTypes =     (
           NSRTFDPboardType,
           NSRTFPboardType,
           NSStringPboardType
       );
   }
Apr 17 15:42:09 aura LaunchBar[54029]: Invalid NSServices entry in /System/Library/Services/AppleSpell.service: {
       NSExecutable = AppleSpell;
       NSLanguages =     (
           "pt_BR",
           "en_GB",
           "en_AU",
           "en_CA",
           nl,
           en,
           fr,
           de,
           it,
           pt,
           es,
           sv,
           da,
           ru,
           Multilingual
       );
       NSPortName = AppleSpell;
       NSSpellChecker = Apple;
   }
Apr 17 15:42:10 aura LaunchBar[54029]: Invalid NSServices entry in /System/Library/Services/OpenSpell.service: {
       NSExecutable = OpenSpell;
       NSLanguages =     (
           "*"
       );
       NSPortName = OpenSpell;
       NSSpellChecker = Open;
   }

And it's reproducible by running Update Index > All Rules [Command-0].

I haven't installed/updated any apps with 5.2 running so until doing that I won't know if the index updating issue is resolved.

nickomore
Posts: 16
Joined: Thu Apr 01, 2010 9:21 am

Re: Problems with Index of 5.2 Nightly (905)

Post by nickomore » Wed Apr 18, 2012 7:48 pm

same problem as others. Hangs on indexing applications and non of my abbreviations are working... hope there is a fix...

sjk
Wizard
Wizard
Posts: 315
Joined: Thu Sep 13, 2007 9:46 pm
Location: Eugene
Contact:

Re: Problems with Index of 5.2 Nightly (905)

Post by sjk » Wed Apr 18, 2012 8:01 pm

Disabling the Use Spotlight index option might be a temporary workaround for the trouble with hangs during indexing. And maybe this is a symptom of the Spotlight index needing rebuilding?

Post Reply