STOP shortcuts from remapping when input source changes

General discussions about LaunchBar
Post Reply
jamiljonna
Posts: 7
Joined: Sat Oct 02, 2010 4:39 am

STOP shortcuts from remapping when input source changes

Post by jamiljonna » Sun Oct 03, 2010 9:36 am

Hello,

I use DVORAK but I also have a Kinesis external keyboard in my office that has it's own remapping function so I'm constantly switching back and forth between Canadian and DVORAK. I've noticed that at least one shortcut setting that I use constantly—invoking clipboard history—changes when I change the input source. I can understand why this functionality may have been implemented but for me it is a total pain. Is there a way to stop this behavior since it may not be desired in cases such as this?

Many thanks.

P.S. I realize that I can pick a key that doesn't change when this particular switch occurs (such as "M" or "A"). Still, this is quite inconvenient for my workflow.

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: STOP shortcuts from remapping when input source changes

Post by manfred » Sun Oct 03, 2010 10:17 am

What shortcut do you use to invoke the clipboard history?

jamiljonna
Posts: 7
Joined: Sat Oct 02, 2010 4:39 am

Re: STOP shortcuts from remapping when input source changes

Post by jamiljonna » Sun Oct 03, 2010 11:18 am

Because I used to use Quicksilver, I'm accustomed to command+L but since Launchbar can invoke globally, I decided on command+alt+L.

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: STOP shortcuts from remapping when input source changes

Post by manfred » Mon Oct 04, 2010 1:23 pm

And if you change the shortcut to cmd+alt+M the import source doesn't change? Do you know if there is an shortcut for »Select the previous / next input source« is defined? Please take a look in your System Preferences -> Keyboard -> Keyboard Shortcuts.

jamiljonna
Posts: 7
Joined: Sat Oct 02, 2010 4:39 am

Re: STOP shortcuts from remapping when input source changes

Post by jamiljonna » Mon Oct 04, 2010 7:21 pm

Sorry for the misunderstanding, manfred: changing the import source works just fine (I use command+alt+space) in either case. I simply meant that since "M" is in the same place on both DVORAK and QWERTY, Launchbar can't remap my shortcut. It will remap letters that are *not* in the same place, however, like "L". Unfortunately, I can't use command+M (as I said, it conflicts with others) so this remains highly annoying because Launchbar keeps changing my preferred shortcut for the clipboard history.

manfred
Objective Development
Objective Development
Posts: 561
Joined: Sat Jul 31, 2010 9:47 am
Location: Vienna
Contact:

Re: STOP shortcuts from remapping when input source changes

Post by manfred » Wed Oct 13, 2010 12:11 pm

please check if and what shortcut is defined for »Select the previous / next input source«

jamiljonna
Posts: 7
Joined: Sat Oct 02, 2010 4:39 am

Re: STOP shortcuts from remapping when input source changes

Post by jamiljonna » Thu Oct 14, 2010 3:32 am

The shortcut I use is: command + alt + space. I'd be interested to know how that makes a difference.

Thanks,

Jamil

Post Reply