Mojave: Launchbar doesn't index Safari

General discussions about LaunchBar
henningberlin
Posts: 2
Joined: Tue Sep 25, 2018 11:47 am

Mojave: Launchbar doesn't index Safari

Postby henningberlin » Tue Sep 25, 2018 11:52 am

You need to give LaunchBar full disk access.

Go to:
System Preferences -> Security & Privacy -> Privacy tab -> Full Disk Access
Click the + then choose LaunchBar. LaunchBar will have to be restarted and then it seems to work!


(Thanks "blackletter" for the hint)

Was
Rank 2
Rank 2
Posts: 70
Joined: Wed Jan 13, 2010 2:27 am

Re: Mojave: Launchbar doesn't index Safari

Postby Was » Tue Sep 25, 2018 6:00 pm

I think it's quite damning that LB support haven't provided any forewarning of issues arising from Mojave. Neither instand send nor the clipboard functions are working for me.

urippa
Posts: 13
Joined: Tue Oct 06, 2009 6:53 am

Re: Mojave: Launchbar doesn't index Safari

Postby urippa » Wed Sep 26, 2018 5:39 am

All working perfectly for me, including instant send and clipboard). Mojave and LB feel very coherent and connected in my entirely subjective, rose tinted opinion.
So my guess is yours might be a preference or settings issue.
Any one of the following might fix the problem.
Try, in this order:
checking your accessibility, and security and privacy settings,
a restart or two,
verifying disc permissions (whatever your favourite approach to that might be),
deleting/sandboxing LB plist (and restart).

Was
Rank 2
Rank 2
Posts: 70
Joined: Wed Jan 13, 2010 2:27 am

Re: Mojave: Launchbar doesn't index Safari

Postby Was » Wed Sep 26, 2018 10:08 am

urippa wrote:All working perfectly for me, including instant send and clipboard). Mojave and LB feel very coherent and connected in my entirely subjective, rose tinted opinion.
So my guess is yours might be a preference or settings issue.
Any one of the following might fix the problem.
Try, in this order:
checking your accessibility, and security and privacy settings,
a restart or two,
verifying disc permissions (whatever your favourite approach to that might be),
deleting/sandboxing LB plist (and restart).


You're right. I was too hasty. I removed and re-added launchbar from accessibility settings and things are back to normal (except firefox bookmarks and history, which is not working. However, I still think what would have been good would be a post like this from the devs: https://forum.keyboardmaestro.com/t/rea ... jave/11637. e.g. Launchbar had accessibility permissions - it was removing them and re-adding that worked, and less savvy users (like myself) might not have known to do that.


Return to “LaunchBar General”

Who is online

Users browsing this forum: No registered users and 1 guest