Instant Send does not seem to work

General discussions about LaunchBar
Post Reply
Posts: 13
Joined: Wed Nov 10, 2010 4:55 am

Instant Send does not seem to work

Post by sims10 » Sat Mar 10, 2018 10:09 pm

10.13.3 High Sierra, Launchbar 6.9.4.
Double Option is the shortcut for Instant Send.

It does not seem to work for me.
Instant send, especially with Finder selections is an important part of how I use Launchbar.

Any clues as to how to enable it?


Posts: 2
Joined: Tue Dec 27, 2016 2:22 pm

Re: Instant Send does not seem to work

Post by brijazz » Wed Mar 28, 2018 12:27 am

Instant Send broken for me too (also using LB 6.9.4 and OS 10.13.3). Logging out/in fixes the issue but it inevitably reappears.

Posts: 13
Joined: Fri Oct 13, 2017 12:04 am

Re: Instant Send does not seem to work

Post by SmithJones » Thu Apr 12, 2018 9:04 pm

It works on 10.12.6 but it has gotten SLOOOOOOOOOOOOOOW...

Also, I use it a lot to highlight a word, then instant-send that word to Merriam-Webster online dictionary, and when I hit MW (for Merriam-Webster) it can take up to 10 seconds or so to do what I want. It used to be a lot faster.

Posts: 1
Joined: Sun Apr 15, 2018 12:27 pm

Re: Instant Send does not seem to work

Post by Martenzi » Sun Apr 15, 2018 2:03 pm

I skimmed this thread and I could possible provide at least a few troubleshooting hints.

Full disclosure:
I have not tested Instant Send too much and don´t know whether I have the same issue (or whether I can reproduce consistently). Overall, Launchbar has shown a few sketchy behaviours with both file operations and key modifiers. Several apps that I use have similar issues of varying nature, relating to file operations and key invokation.
[*] I may be slightly incorrect in my explanation of how some details of macOS works, but overall gist is verified empirically and my knowledge is the result of very tedious troubleshooting and googling.

    Hint 1:
    Since High Sierra and Apples most recent security upgrades, multiple 3rd party apps have/had had trouble getting permission to do file operations. The mix I use is simply that there has been various issues with respective app, all seems to relate to security, not only permissions (sandbox integration, gatekeeper etc.).
    Path Finder

  • Launchbar, Alfred, Path Finder and Forklift can generally display that it successfully copied/moved a file or folder, but when I verify, it does not always work as intended. Moving files from outside to HOME folder and/or MacHD is causing issues with permission, despite the user having properly defined it in traditional sense.
  • This issue IS NOT automatically fixed by repairing disk permissions alone and as far as my investigation can tell, there is a grey area of whether this is a bug or as another user put it "Apples solution to tighten their security is effectively a thick, Great Wall of China, that has no obvious staff department for enquiries."

    Potential Solution: If an App that resides anywhere (~/App.. or /App... or Desktop etc) gives sketchy warning messages or unsuccessful file operations, check that it is not running in App Translocation and thus put to Quarantine list.
    One fix that may solve some problems (often relating to App Translocation) is to invoke in terminal:

    Code: Select all

    xattr -d /Applications/Path/to/App/binary

  • If the app is not quarantined, this will give an error message saying something like "no such attributes to file/dir).
  • If the app has been flagged with quarantine, this command does not give any output.
  • Note:
    This command does not neccessarily require sudo.
    Try sudo at your own risk, if if non-sudo does not seem to work or make any difference.
  • The command is simple removing the flag attribute in The Quarantine Database that deals with "Install apps from Unidentified Developers". Why this is not handled automatically or more effectively by macOS is also a grey area of bug or super security without proper guidance to the user by Apple.
  • A confusing thing to a lot users, incl myself, is that we get the impression that apps in Sandbox is BAD thing. Most System apps that deals with outside communication are sandboxed and automatically handled by macOS. I thought modifying some of my own apps that I found in Sandbox would solve some issues, but that was an uneducated and stupid move.

    Hint 2:
    Another key thing in some cases is that macOS has put Read-only on the users own ~/Applications, which is NOT correct and simply changing the permissions is tricky for noobs, as many users have applied Recursive permissions to entire ~/Applications folder and this in itself, can cause major issues.
  • The solution is to only give full Read/Write to the top level, where the apps are located, NOT traverse into each AppBundle.
  • Dont confuse this with the System wide /Applications folder. Those permissions ought to be correct from start and should not be tampered with.

    Hint 3:
    After several futile attempts to work out permission for various apps, and they seems to be perfectly fine (most attempts resulted in a reset/disk repair), I found out that 3rd party apps may have invalid code signature which is seriously detected by macOS security and can therefore result in sketchy app functionality.
    The most depressing part of this is that Apple has given no solution to these issues besides telling app developers to adhere to their coding guidelines for security (which has very limited documentation) or risk becoming Unsupported. The consequences of this is that a lot of apps on MAS is outdated and no longer supported by the developers. Some Developers have been forced to rewrite entire apps simply because Apples security is extremely enclosed and the company has received criticism for being uncooperative and lacking sufficient documentation on how macOS works. This is especially relevant on any app that seeks to enhance the core functionality.

Posts: 5
Joined: Wed Jun 03, 2015 3:59 pm

Re: Instant Send does not seem to work

Post by Strandbummler » Fri Sep 21, 2018 10:07 pm

Since recently I have the same problem. After I restart Instant Send works fine. But after a while it's just gone. Changing the hotkey doesn't work and restarting launchbar neither. It's really annoying since i use this all the time. Feels like someone cut off one of my fingers.

Rank 1
Rank 1
Posts: 31
Joined: Thu Nov 17, 2011 3:22 pm

Re: Instant Send does not seem to work

Post by davemee » Tue Oct 23, 2018 12:40 pm

Hate to me-too, but me-too this issue. I've tried every variation of double-tap ctrl/alt keys, single-tap, nothing works. Instant send is a key part of Launchbar - I've almost stopped using it since this broke. I tried @martenzi's tips but to no avail.

And 2nding @strandbummier's point that it feels like I've lost - specifically - my thumbs. Instant send it a key part of how I use DEVONthink! ( sad smiley emoji )

Posts: 1
Joined: Fri Dec 28, 2018 6:33 pm

Re: Instant Send does not seem to work

Post by krizzmp » Fri Dec 28, 2018 6:34 pm

I managed to get it to work after turning on accessibility access in system preferences

Rank 1
Rank 1
Posts: 31
Joined: Thu Nov 17, 2011 3:22 pm

Re: Instant Send does not seem to work

Post by davemee » Tue Jan 08, 2019 3:43 pm

I have it working again, but I have no idea why!

To resolve this, I opened System Preferences→Shortcuts→Services and just randomly clicked around. I changed one. non-conflicting shortcut key.

As soon as I closed the window and tried instant-send (I'm nostalgic!), *it worked!!!*

No idea why this works, but leaving it here if it's any use for anyone else, as it's a non-obvious solution (and may not even be the solution that actually fixed it, but it's worth a shot!)

Post Reply