LB 6.5 and iTerm2: Cmd + T doesn't open window

General discussions about LaunchBar
Post Reply
nemozob
Posts: 5
Joined: Fri Jun 15, 2012 8:14 pm

LB 6.5 and iTerm2: Cmd + T doesn't open window

Post by nemozob » Fri Feb 26, 2016 1:30 am

I've set Launchbar to use iTerm2 as my preferred terminal application. Here's what I'm experiencing:

- double-tap command to Instant Send a Finder directory to LB
- hit command-t
- iTerm2 launches/comes to the front but no window opens

Anyone know where the problem is? I can use an Automator Service to accomplish this so I know iTerm will open directories.

LaunchBar 6.5
OS X 10.11
iTerm2 2.9

sas
Posts: 1
Joined: Thu Apr 07, 2016 9:15 am

Re: LB 6.5 and iTerm2: Cmd + T doesn't open window

Post by sas » Thu Apr 07, 2016 9:23 am

I'm having the same issue with Cmd-G, Cmd-T (which is the same thing as your shortcut, I believe). I recently switched to iTerm2 and despite selecting it as the terminal app it does not open a new window and `cd` to the Finder directory. What it will do however, is bring iTerm to the front (but no new window or any `cd` action).

This is iTerm2 Build 2.9.20160313.

Not sure if this is relevant but I noticed is that LB refers to "iTerm" and that is also the app name in the doc. However the process name is "iTerm2".

LaunchBar 6.6 (6126)
OS X 10.11.4
iTerm2 Build 2.9.20160313

pgsm
Posts: 2
Joined: Fri Dec 29, 2017 5:34 pm

Re: LB 6.5 and iTerm2: Cmd + T doesn't open window

Post by pgsm » Fri Dec 29, 2017 5:56 pm

Hi there,

I was wondering if, with the latest launchbar, is the iTerm2 version3
issue still present?

On my system the commant+T shortcut no longer works if I choose iTerm
as my default terminal.

Any news?
TIA.

Post Reply