LS v3.5 brick my MacBookPro (Yosemite) ?!?

General discussions about Little Snitch
Post Reply
anme
Posts: 2
Joined: Sun Nov 16, 2014 6:41 pm

LS v3.5 brick my MacBookPro (Yosemite) ?!?

Post by anme » Sun Nov 16, 2014 6:58 pm

Hello everyone,

I updates LittleSnitch to the version 3.5.
As part of the installation process I rebooted the MacBookPro by clicking the Reboot-button in the installer-window.
The Mac showed the Apple logo. After that the monitor turned gray an a crossed circle is displayed. Insted of the login-screen.
I turned the Mac o/off a few times, without any luck.
So I started the recovery-partition and cheked/repaired the SSD (Volume & permission), without any luck.
The Mac is still not booting.
The SMC reset was unsuccessfully, too.

Right now, I am restoring the system via TimeMaschine. Hope that works....
p.s. My MacBook Pro is fully up-to-date (OSX Yosemite).

Is anybody experiencing the same issue?

From germany with best regards.

anme
Posts: 2
Joined: Sun Nov 16, 2014 6:41 pm

Re: LS v3.5 brick my MacBookPro (Yosemite) ?!?

Post by anme » Sun Nov 16, 2014 10:13 pm

Hey,

I solved the issue.

A Kernel-Extension stopped the system during boot.

I enabled TRIM with TrimEnabler. The tool deactivates a security mechanism of Yosemite, wich prevents the system from executing unsigned Kernel-Extensions.
For some reason (i don't know which, yet) the reboot after the installation of LittleSnitch re-activated that security-mechanism and the system did`t boot completely.

I solved it, according to the following instruction:
http://www.cindori.org/trim-enabler-and-yosemite/
"Recovering from stop sign on boot screen" didn't work. But "Reversing any changes by Trim Enabler" did the job.

Yet I didn't re-activated TrimEnabler. I`ll try that tomorrow....

btw: Restoring from a Backup didn`t solved the issue.

Good night.

rmschne
Posts: 3
Joined: Sun Nov 16, 2014 9:44 am

Re: LS v3.5 brick my MacBookPro (Yosemite) ?!?

Post by rmschne » Mon Nov 17, 2014 10:48 am

See my post. I solved by booting into safe mode with SHIFT key depressed during boot. Then uninstalled Little Snitch. Then on next real boot got machine back. Have not, and probably will not, reinstall.

Hugo
Posts: 9
Joined: Fri Nov 14, 2014 11:23 pm

Re: LS v3.5 brick my MacBookPro (Yosemite) ?!?

Post by Hugo » Mon Nov 17, 2014 12:01 pm

I enabled TRIM with Chameleon SSD Optimizer.
LS v3.5 didn't stop the boot of my Mac but caused some problem to XAMPP (mysql launch at login).

Janberlin
Posts: 1
Joined: Mon Nov 17, 2014 6:56 pm

Re: LS v3.5 brick my MacBookPro (Yosemite) ?!?

Post by Janberlin » Mon Nov 17, 2014 6:59 pm

I could not get into the safe boot mode. Drove me mad. Tried also 1st solution mentioned by anme and didn't work neither. But the second one reverse changes did. Phew. Thanks for the hint. Never though of the trim enabler conflict.

Post Reply