LS and Xcode 6

General discussions about Little Snitch
Post Reply
ik2wxx
Posts: 7
Joined: Tue Apr 09, 2013 9:19 am

LS and Xcode 6

Post by ik2wxx » Tue Sep 16, 2014 6:47 am

Hello there
I'm using LS on OS X Yosemite and Xcode 6 GM
When starting an app on the simulator, every time LS asks for internet permission to run the app.
With the previous versions of Xcode, the permission was only asked the first time.
Now it's asked every time I start the app.
(maybe the app file is now always delete before run? I don't know)
Can I grant the access to the app only once, as before ?
Asking the same app permission all the time is frustrating...so I have to turn off LS which is not what I want to do.
Tnx
Roberto

jleishman
Posts: 1
Joined: Tue Sep 16, 2014 8:00 pm

Re: LS and Xcode 6

Post by jleishman » Tue Sep 16, 2014 8:01 pm

I'm experiencing the same thing. If you make any progress with this please update the thread.

ik2wxx
Posts: 7
Joined: Tue Apr 09, 2013 9:19 am

Re: LS and Xcode 6

Post by ik2wxx » Fri Sep 19, 2014 3:50 pm

Yes now I'm sure, every time an app is started on the simulator, Xcode 6 deletes the entire folder with the old version and create a new folder (with different name) and put the new app in it, so you have to re-allow network connection for the app.
With Xcode 6 the folders are created in the (user folder)/Library/Developer/CoreSimulator/Devices/(device id)/data/Containers/Bundle/Application/(temporary app id)
Roberto

JetForMe
Posts: 1
Joined: Tue Sep 23, 2014 11:16 pm

Re: LS and Xcode 6

Post by JetForMe » Tue Sep 23, 2014 11:33 pm

I, too, am seeing this problem with Xcode 6.

I tried creating a manual rule with the Process field set to "MyApp", but that doesn't work, even though the process name as listed by ps is "MyApp." Unfortunately, there appears to be no way to match a partial path with Little Snitch. This would be very useful for us developers.

Karsten Gresch
Posts: 1
Joined: Mon Oct 06, 2014 5:09 pm

Re: LS and Xcode 6

Post by Karsten Gresch » Mon Oct 06, 2014 5:34 pm

Wouldn't it be useful having a regex/wildcard matching rule for files/folders? IIRC Hands Off has it and at the moment I consider switching as it is *so* annoying having LS popping up every time I run a build... :-|

karl
Objective Development
Objective Development
Posts: 75
Joined: Thu Nov 16, 2006 10:20 pm

Re: LS and Xcode 6

Post by karl » Tue Oct 07, 2014 4:23 pm

Rest assured that we’re working on a solution to this issue with apps running in the iOS Simulator. A Little Snitch Nightly Build that addresses this will be available soon.

infrid
Posts: 3
Joined: Mon Sep 17, 2012 6:05 pm

Re: LS and Xcode 6

Post by infrid » Tue Oct 07, 2014 9:18 pm

Me too. This is driving me totally nuts. I must've pressed accept about 500 times now.

If there's no fix your end, is there anything we can do to workaround it.. getting pretty close to uninstalling.

cocoapriest
Posts: 1
Joined: Wed Oct 08, 2014 2:04 pm

Re: LS and Xcode 6

Post by cocoapriest » Wed Oct 08, 2014 2:06 pm

Yes, it's very annoying. The fix can't come soon enough!

infrid
Posts: 3
Joined: Mon Sep 17, 2012 6:05 pm

Re: LS and Xcode 6

Post by infrid » Fri Oct 10, 2014 5:24 pm

Any news on the nightly build.

I'm an iOS developer. I really can't go another week with this.

karl
Objective Development
Objective Development
Posts: 75
Joined: Thu Nov 16, 2006 10:20 pm

Re: LS and Xcode 6

Post by karl » Thu Oct 16, 2014 8:44 pm

Good news everyone! We just want to inform you that we just released a new nightly build (Little Snitch 3.5) with improved support for iOS Simulator apps. You can have a look at http://blog.obdev.at for some details.

ik2wxx
Posts: 7
Joined: Tue Apr 09, 2013 9:19 am

Re: LS and Xcode 6

Post by ik2wxx » Fri Oct 17, 2014 8:07 am

karl wrote:Good news everyone! We just want to inform you that we just released a new nightly build (Little Snitch 3.5) with improved support for iOS Simulator apps. You can have a look at http://blog.obdev.at for some details.


Works ok for me !!!
Tnx
Roberto

Post Reply