LS2 Network monitor using 50% CPU with Azureus running

General discussions about Little Snitch
Post Reply
Cristalballons

LS2 Network monitor using 50% CPU with Azureus running

Post by Cristalballons » Sun Nov 11, 2007 10:05 pm

I have the following rule set for Azureus:

Allow connections to port 1024-65535
Allow connections to port 80
Deny connections to port 1-1023

The LS2 network monitor really seems to be struggling with this, probably in denying connections to port 1-1023. LS1 had no problem with this rule set. Is LS2 doing multiple lookups where LS1 was not?

Guest

Post by Guest » Mon Nov 12, 2007 2:18 am

Turn off "Network Monitor" in the Monitor tab of LS preferences while Azureus (or any torrent client, p2p client, etc) are in use.

LS will still protect you, you're just disabling the monitor feature.

johannes
Objective Development
Objective Development
Posts: 815
Joined: Fri Nov 10, 2006 4:39 pm
Contact:

Post by johannes » Mon Nov 12, 2007 6:27 pm

It seems that this is a problem of the Network Monitor in combination with BitTorrent clients, as these applications do create hundreds or even thousands of connections to different hosts.

We are currently investigating the problem. As a workaround you do not need to disable the whole Network Monitor - you can just hide your BitTorrent client from the Network Monitor - to do so:
  • Select the BitTorrent client application in the Network Monitor
  • Click the action menu button (the gear wheel icon) in the upper left of the Monitor window
  • Choose "Don't show xxxxx in Network Monitor"
  • The rule editing window will be shown, click OK to save the rule
In this special situation it's then best to turn the Network Monitor off and on again - to do so:
  • Click the action menu button again and choose "Preferences..."
  • In the appearing preferences window, turn the Network Monitor off and on again.


We will do our best to solve this issue ASAP.

sith250
Posts: 8
Joined: Tue Nov 13, 2007 11:50 pm

Post by sith250 » Wed Nov 14, 2007 12:07 am

Could this be the reason LS keeps knocking out my Airport Base Station forcing me to reset it all the time? I am running Azureus when it happens...

Post Reply