General discussions about Little Snitch
Post Reply
Posts: 2
Joined: Fri Nov 09, 2007 6:09 pm


Post by marhk » Fri Nov 09, 2007 6:15 pm

Using 10.4.10 on a MBP.
LS 2 screws up all my widgets. There is sometimes a request for connection - which can then be answered. The widget then will work - but, slowly. Mostly, there is no request for access and the widgets won’t work at all.
Can we fix this? This currently is a deal breaker.

Posts: 5
Joined: Fri Nov 09, 2007 9:21 pm

Widgets not working for me either

Post by bradsmith74 » Fri Nov 09, 2007 9:25 pm

Same situation as marhk. Installed LS2 this morning and upon reboot, the only widget that still worked was Apple's Stocks widget. All of the other are dead. But LS2 never notified me of a connection attempt for them that it was denying- it's almost like it denied them automatically without asking me, and (as far as I can tell) without recording anything in LS2's configuration application (I don't see anything listed). 10.4.10 on a mini.


widgets broken

Post by pgowing » Sun Nov 11, 2007 6:10 am

:cry: Like the last two post my widgets are also broken -- including apple's weather widget. (the only one that works is the stock price widget.) PLease fix! (OS 10.4.10 on a G5 PPC Tower.)

Posts: 3
Joined: Sun Nov 11, 2007 11:40 am


Post by Trilobite » Sun Nov 11, 2007 11:51 am

I'm having the same problem with LSv2 preventing my Internet accessed widget information from connecting. Internal Widgets work fine like calculator and dictionary. It's weather and traffic and such that remain empty and non functional due to LSv2.

Uninstalling LS and restarting brings back all Widget functionality.
I'm currently running Leopard on a new Intel iMac.


Post by Guest » Sun Nov 11, 2007 1:32 pm

I am now running LS2 under Leopard and I ran several LS2 betas under both Tiger and Leopard. I do not have any trouble at all with widgets and never did, neither the ones that came with the OS, self-built ones (with Safari) or third party widgets.

Amongst my rules is one that says 'DasboardClient: allow all connections'.

I cannot remember if I once okayed a DashboardClient request by LS2 or if this was imported from my LS1 rules.

But anyway: You don't have to wait for Little Snitch to ask you for the permission for a connection – almost anytime this is the most comfortable way to do so. But in this case you could manually add this rule by clicking on new rule and chose the Dashboard in the section 'programs', can't you?

Objective Development
Objective Development
Posts: 648
Joined: Thu Nov 09, 2006 6:30 pm

Post by norbert » Sun Nov 11, 2007 3:55 pm

I'm unable to reproduce this issue here. Please file a bug report at http://www.obdev.at/littlesnitch/support.html. Our support team will then try to help you tracking down this issue.


widgets reloaded

Post by pgowing » Mon Nov 12, 2007 4:03 am

SO after whining about it yesterday, I have a work around. Close out the offending widget of your dashboard and replace it onto your dash again. When it re-loads it will ask permission for net access.

Posts: 2
Joined: Fri Nov 09, 2007 6:09 pm


Post by marhk » Mon Nov 12, 2007 5:50 am

Try a restart. With my system on 10.4.10 on a MBP upon restart they are all screwed up again. I agree that by reintroducing all the widgets I can have them all work. But it doesn’t last from restart to restart! :cry:


Post by nilok » Wed Dec 19, 2007 8:04 pm

I'm having a similar problem, but in my case one of my 3 weather widgets works fine, but the other 2 I keep never seem to get through. I have a rule in for the weather widget, as well as a rule in for dashboard that should allow connections, so I have no idea why this is going on.

Posts: 1
Joined: Thu Nov 16, 2006 10:17 pm

Post by Scooter » Fri Jan 04, 2008 3:17 am

I solved the problem by just tossing dashboard in the trash. It was a nuisance to begin with. everything it does can be done above the desktop with other apps. Weather is in the menu-bar at the top. Who needs to shove the desktop to the back just to find the temp? only to have to click thru to bring the desktop back.

Nice gimmick but still dashboard is just a gimmick. A bell or whistle that has no real function for productivity.

Brianna Masson
Posts: 1
Joined: Wed Feb 27, 2019 6:40 am

Re: Widgets

Post by Brianna Masson » Wed Feb 27, 2019 6:41 am

The forum of the latest range and product is consumed by the minor group of the society. This has been assured for the brief calculation and ukacademicwriters review in the midst of the calculations. The reign is depicted for the approval of the methods of the research upon the blogs and artistic work for the parents.

Post Reply