Stop Incoming Emails from Connecting Back to Host Server?

General discussions about Little Snitch
Post Reply
JollySnitch
Posts: 4
Joined: Sat Nov 10, 2012 6:20 am

Stop Incoming Emails from Connecting Back to Host Server?

Post by JollySnitch » Sat Nov 10, 2012 7:09 am

I just got a new (used but clean) MacBook (OS 10.7 Lion) and immediately installed LS 3.0, and I feel like it will always be safe. Great product!

Every time I view a received email from a business (including a lot of spam), the LS authorization screen pops up, sometimes 2-3 times per email (to retrieve images or send receipt verifications or track web activity). I want to stop this constant authorization step by setting a rule in LS directing: "Do Not Attempt to Connect to Host Server (*) Until I Decide to Manually Allow Connection."

(*) = The hard part.

I set a rule in LS to Deny all Outgoing Connections for application Mail. However, I can't seem to set a qualifier that says "...Until I Decide to Manually Allow Connection."

Can anyone instruct me on how to customize this rule? Big thanks!

hagen
Wizard
Wizard
Posts: 594
Joined: Mon Feb 18, 2008 11:05 pm

Re: Stop Incoming Emails from Connecting Back to Host Server?

Post by hagen » Sat Nov 10, 2012 5:13 pm

You can open the rules screen and disable the blocking rule temporarily. That's what I do for this problem.

JollySnitch
Posts: 4
Joined: Sat Nov 10, 2012 6:20 am

Re: Stop Incoming Emails from Connecting Back to Host Server?

Post by JollySnitch » Sat Nov 10, 2012 10:26 pm

hagen wrote:You can open the rules screen and disable the blocking rule temporarily. That's what I do for this problem.


Hagen, your ID shows you as being a Wizard, so I take your word as gospel. Thanks for the reply.

This is rather disappointing. I get up to 100 emails each day, and about 10-20 are worthy of allowing them to connect back to their sending server upon my opening them. It will be very time consuming and downright bothersome to have to load LS, open Rules, turn off this rule, go back to my Mail client, view the selected email(s) so that it may communicate back to it's source, and then go back to LS to turn this rule on again. What a major drag!

Can you, or can anyone else please, suggest a way to custom design a rule to allow connection of individual emails without leaving Mail and going into LS? I can envision a keystroke one-time allowance. HELP!

Thanks, all....

hagen
Wizard
Wizard
Posts: 594
Joined: Mon Feb 18, 2008 11:05 pm

Re: Stop Incoming Emails from Connecting Back to Host Server?

Post by hagen » Sun Nov 11, 2012 1:45 am

"Wizard" just means I'm old and wizened. :mrgreen:

I can see, in your case, that turning the rule off and on would be a major pain. A better way to do this is within the email app itself, if you can find one that gives you the tools. I have a very old Thunderbird that can be set to view messages as "plain text" or "Simple HTML", and it won't try to retrieve remote images or send receipts. Then, when I'm viewing a message, I can click a menu item to "view as HTML". It will then call out and in this case Littlesnitch is set to allow.

Those are the only options I can think of.

JollySnitch
Posts: 4
Joined: Sat Nov 10, 2012 6:20 am

Re: Stop Incoming Emails from Connecting Back to Host Server?

Post by JollySnitch » Sun Nov 11, 2012 7:24 am

hagen wrote:I can see, in your case, that turning the rule off and on would be a major pain. A better way to do this is within the email app itself, if you can find one that gives you the tools.


Thank you for the consultation and suggestions. There are many criteria I use to pick my email client; I won't change clients based on one manipulatable feature. I'm using Mac Mail on three devices and it's working well (especially now that I've got it to play nicely with the Google mail settings).

So, if LS can't be customized to do what I need it to do, I'll have to look toward customizing Mail. (I guess I'll just call Apple tomorrow and ask them to work up a solution by next week. Ha.) LS offers too much valuable security to abandon it for this one annoyance, and Mail is too functional and seamlessly integrated to abandon for lack of optimization.

I suppose I'll just accept my situation and be happy, while continuing to seek improvements along the way.

Best regards.....

Stuart
Rank 2
Rank 2
Posts: 40
Joined: Tue Feb 01, 2011 3:02 pm

Re: Stop Incoming Emails from Connecting Back to Host Server?

Post by Stuart » Sun Nov 11, 2012 2:41 pm

In my Apple Mail you can enable/disable the automatic download of images in HTML messages. In Mail Preferences, select the Viewing icon/options and in there should be a check box that says "Display Remote images in HTML messages". If you disable the images, the message is displayed with "placeholders" (small question mark" but the message also includes a new banner with a "Load Images" button (so if you want to see the images you just press that button and images are downloaded for that message only (i.e. does not change the preference setting).

Stuart

JollySnitch
Posts: 4
Joined: Sat Nov 10, 2012 6:20 am

Re: Stop Incoming Emails from Connecting Back to Host Server?

Post by JollySnitch » Sun Nov 11, 2012 9:46 pm

Stuart,

Thanks, that did the trick, almost completely! (I'm sure I tested that before posting here. Hmmm. Old age.)

Unchecking "Display remote images in HTML messages" did indeed stop emails from reaching back to their source server to retrieve emails. I was concerned that they were establishing connections for more nefarious purposes. Now, I can load images and make connections on a mail-by-mail basis. Awesome.

I just tested it and found that 99% of emails stopped attempting a connection. The few emails that did still try, for nefarious or other purposes, were from friends using Apple's me.com accounts (attempting connection to homepage.mac.com)! Hmmm, nefarious indeed. ;)

I will delete that user-created rule to block all Mail outgoing connections and rely on Mail itself to protect that road into my laptop with LS as the true gatekeeper.

Big Thanks.....

TotaFarrod
Posts: 1
Joined: Fri Dec 14, 2012 12:34 pm

Re: Stop Incoming Emails from Connecting Back to Host Server

Post by TotaFarrod » Fri Dec 14, 2012 12:38 pm

I had the same problem and after going through these replies, I was able to solve it. Saved lot of time to me. Thank you very much for all............. :D

Post Reply