Page 1 of 1

LS does not remember rules regarding Google Chrome

Posted: Mon Mar 12, 2012 8:49 am
by sghiassy
Hi,

First of all, love Little Snitch. Great app.

My problem though, is that Little Snitch does not remember my firewall rules when using Google Chrome. I can't remember how many times, I've approved or denied the same rule over and over and over.

Little Snitch only does this with Google Chrome and does not exhibit this behavior with any other application. I have seen Little Snitch do this on my 2010 Mac Book Pro with 10.7 on it and also my Mac Pro with 10.6 on it; same behavior.

Is anyone else having this problem?

Re: LS does not remember rules regarding Google Chrome

Posted: Wed Mar 14, 2012 8:45 pm
by sghiassy
Seriously... has no one else approved use of port 1935 for Flash in Google Chrome a thousand times?

Re: LS does not remember rules regarding Google Chrome

Posted: Fri Mar 16, 2012 2:14 am
by hagen
There's not many of us here, and I don't use Chrome. Maybe I could figure out something if I had more details of what's going on in LS.

Is it Chrome that asks to use port 1935, or Flash, or some other process? By that I mean, what is listed at top of the popup?

Can you get any clues from the rules screen, like disappearing rules or anything odd?

Re: LS does not remember rules regarding Google Chrome

Posted: Thu Jun 28, 2012 4:11 pm
by soboku
I to have this problem. I will start writing down what the popups are saying from here on so we no what its asking for. Adding to this I am seeing that little snitch is not remembering rules for some others as well. I am constantly having to re-set rules I have already did in the past and not just for Chrome.

Re: LS does not remember rules regarding Google Chrome

Posted: Thu Aug 09, 2012 6:31 pm
by strongfinger
it's the google update that doesn't seem to stick.
same port (443), same protocol, same preference of 'always allow'.

Re: LS does not remember rules regarding Google Chrome

Posted: Fri Aug 10, 2012 12:57 am
by strongfinger
the most common message i get (the others only happen after a reboot):

"ksfetch" (nobody)

wants to connect to tools.google.com on TCP port 443
(https)

screen capture here:

http://i46.tinypic.com/23ll8wp.png

Re: LS does not remember rules regarding Google Chrome

Posted: Fri Aug 10, 2012 5:15 pm
by hagen
There's another thread about ksfetch: viewtopic.php?f=1&t=6720

This is Google being difficult, spawning a new process for every callout.

I wonder if there are a limited number of destination addresses involved, or if one could find some pattern. If so, maybe allowing "All Applications" to those addresses would be an acceptable workaround. That's just an idea, I have no Google stuff so can't check it myself.

Re: LS does not remember rules regarding Google Chrome

Posted: Fri Aug 10, 2012 7:46 pm
by watersb
hagen wrote:This is Google being difficult, spawning a new process for every callout.


Agreed. I wonder if you could get the path of the process, verify its signature somehow. Maybe Mountain Lion has some way to move in that direction.

Re: LS does not remember rules regarding Google Chrome

Posted: Tue Aug 14, 2012 10:15 am
by karl
@strongfinger Your screen shot indicates that you are using a long time outdated version of Little Snitch!

This issue has been fixed since Little Snitch 2.3 in 2010. Please upgrade to the latest version 2.5.x or version 3.x available at:

http://www.obdev.at/products/littlesnitch/download.html

After finishing the upgrade you may want to activate the automatic software update. Little Snitch Configuration -> Preferences -> Update