LS allowing all connections

General discussions about Little Snitch
Post Reply
ryansebiz
Posts: 5
Joined: Sat Jun 28, 2008 8:03 pm

LS allowing all connections

Post by ryansebiz » Sat Jun 28, 2008 8:06 pm

LS allows all connections and has stopped prompting me to allow or deny. Running LS 2.0.3 with Leopard 10.5.3.

I used the dmg's uninstall feature, restarted, reinstalled and restarted again.

I'm using a Standard account. When I switch to the Admin account the normal allow/deny prompts appear.

In my account, when I manually add a deny rule, for example Firefox, it does completely block it. However, when I delete all Firefox rules LS allows all connections without prompting me to allow or deny. The Network Monitor is turned on.

Why is LS allowing all connections? How can I get it to return to normal?

ludwigschubert
Rank 4
Rank 4
Posts: 285
Joined: Fri Jun 29, 2007 5:54 pm
Location: Germany, Bavaria

Post by ludwigschubert » Sat Jun 28, 2008 9:37 pm

It sounds like you have accidentally added a rule that allows all applications any connection:
Image

If there is no such rule, we have to dig deeper, or eventually switch to a new standard user account and see whether the problem persists.

ryansebiz
Posts: 5
Joined: Sat Jun 28, 2008 8:03 pm

Post by ryansebiz » Sat Jun 28, 2008 10:42 pm

ludwigschubert wrote:It sounds like you have accidentally added a rule that allows all applications any connection:


ludwigschubert, you're a genius. That solved the problem. Thank you.

Post Reply