LS 4.2 and Time Machine issues

General discussions about Little Snitch
Posts: 2
Joined: Thu Jan 03, 2019 3:05 pm

LS 4.2 and Time Machine issues

Postby SmokeJaguar » Fri Jan 04, 2019 10:14 pm

Hello all,

First post - so please be kind.

I recently replaced my old NAS with a newer QNAP, and post-the 4.2 update I am encountering some issues that appear to be unique to Little Snitch. Specifically, if network monitor is running at all (including Silent Allow mode), backupd errors out when attempting to connect to the NAS with "Error 18: The backup disk could not be found". I'm confident that this is related to Little Snitch at this time because a) my other macs without Little Snitch do not have this issue at all, b) testing with a second MacBook has shown the same issues and c) turning off the network monitor, starting a backup with Time Machine and then turning on the network monitor allow the TM backup to process with no issues.

Given this, I've reset the rules to factory stock, and have run Little Snitch specifically in permissive mode to see if that resolves the issues. No new login rules/suggestions were found, and I'm seeing the same issues post reset/permissive mode.

Has anyone else run into this? Any thoughts?


Posts: 16
Joined: Sat Nov 19, 2016 12:15 am

Re: LS 4.2 and Time Machine issues

Postby maelcum » Wed Jan 16, 2019 8:17 pm

Using multiple Mojave machines all on 10.14.2, LS 4.2.4 (and all earlier versions since 3.something), QNAP with current firmware version and Time Machine without any problems.
Have you tried to create a new account on the machine that has problems, configure time machine there and try to backup? It could very well be the account having a problem, not LS.

Posts: 2
Joined: Thu Jan 03, 2019 3:05 pm

Re: LS 4.2 and Time Machine issues

Postby SmokeJaguar » Sat Jan 19, 2019 11:25 pm

Yes, I have tried this. The account and machine both work well - BUT, only if the network filter is turned off. At this point, I have exhausted most normal trouble shooting...the problem is something to do with how network filter is configured, but neither reinstalling nor clearing all the rules has resolved it. At this point, I think that Little Snitch may not be long for life on this machine, which is a shame as it has been a great product for me in the past.

My QNAP version is - so we may be seeing some of the problem here, but that should not explain the network filter issue.

I do appreciate the suggestion though, thanks! :D

Rank 2
Rank 2
Posts: 43
Joined: Fri Jan 25, 2008 7:35 am
Location: Ann Arbor, MI, USA

Re: LS 4.2 and Time Machine issues

Postby cortig » Tue Jan 22, 2019 5:29 pm

The latest nightly build that came up today had something interesting in its release notes:
Fixed an issue causing Time Machine backups to Samba servers to stop working under some circumstances.

I've had issues with Time Machine on a Synology drive for a while now (after a while, I was getting a warning telling me that the required features for TM were not supported on the drive) and I have high hopes that this will correct the problem.


Return to “Little Snitch General”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests