LS no longer displays Connection Alerts for new apps

General discussions about Little Snitch
Post Reply
JT X
Posts: 2
Joined: Sat Jan 26, 2008 8:00 am

LS no longer displays Connection Alerts for new apps

Post by JT X » Sat Jan 26, 2008 8:09 am

LittleSnitch's Connection Alert no longer appears on my machine. If I install a new app, it's automatically blocked from making any connections. I've resorted to manually adding all new apps with an "Allow any connection" rule just to get things functioning. What preference turns the alerts back on?

ludwigschubert
Rank 4
Rank 4
Posts: 285
Joined: Fri Jun 29, 2007 5:54 pm
Location: Germany, Bavaria

Post by ludwigschubert » Sat Jan 26, 2008 6:44 pm

You should check whether "Confirm Connection Alert automatically" is checked: (if so, uncheck it)

Image

Also, make sure there was no Deny All-Rule in Place before you created your Allow All-Rule.

If you can find nothing, try a new user account and see whether it works there… if so, you could reset your Little Snitch rules via Little Snitch Configuration Menu: Rules>Restore Factory Rules...

I hope I could help you,
Ludwig

JT X
Posts: 2
Joined: Sat Jan 26, 2008 8:00 am

Post by JT X » Tue Feb 05, 2008 7:01 am

I've done this, and the connection alerts still don't appear. Software Update, for example, tells me that it cannot connect to the Internet, even though it can see that there are updates I haven't applied.

tomtomgone
Posts: 1
Joined: Tue Feb 12, 2008 2:48 am

missing alerts

Post by tomtomgone » Tue Feb 12, 2008 2:51 am

i had the same issue, tried uninstall/reinstall to no effect.

the problem was was in the Rules window, at the bottom of the 'All Applications' entry was a rule for 'Deny all connections'

after deleting that, little snitch worked as before.

i have no idea how that got added, but removing it fixed the problems.

Post Reply