Page 2 of 7

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Sat Oct 27, 2018 11:38 am
by Spamo1958
Here sometimes stops the boot completely.
I have to make a forced shut down and to restart till the iMac Pro turns on.
Not always, by luck, sometimes.

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Mon Oct 29, 2018 8:47 am
by Borg
iMac Retina 5k, yesterday I have fully reinstalled Mojave, clean install from USB, LS 4.2.2.

At first the problem seemed to be solved but now, the problem is back, the boot bar advances to 70% pretty fast and then it slow down (boot time 2-3 minutes vs 20-30 seconds without LS).

Note: the problem present itself ONLY after a cold boot after a while (the problem never shows when doing a reboot).

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Mon Oct 29, 2018 11:24 am
by Bruno
I agree 100% , problem is ONLY after a cold boot, never when doing a reboot.

Mojave 10.14 (18A391)
MacBook Pro TB 2017 (Wifi)
MacMini Late 2012 (Ethernet)

Same issue on the 2 machines

A very long hang on boot, and after desktop appears, there is no DHCP, with all the problems of local network that implies, have to renew DHCP to get it work.

As it was said, the boot bar advances to 70% pretty fast and then it slow down for 15 sec, Black Screen, then 5/10 seconds later the desktop.

I'm right now trying the 4.3 Nightly (5224), i will give u informations later if this is fix.

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Oct 30, 2018 9:16 am
by Spamo1958
Yes , problem is ONLY after a cold boot, never when doing a reboot.
But we are here in this forum talking about this issue and I wonder what Little Snitch staff is doing.
Does someone of them read the forum or the fix is up to the customers?

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Oct 30, 2018 9:44 am
by juanmiguel
I have the same problem...

Problem only after cold boot.
From boot in 20s to take 2 minutes.

As other users was said, the boot bar advances to 70% pretty fast and then it slow down for 15 sec, Black Screen, then 5/10 seconds later the desktop.

Once started, the LS icon in the top menu bar takes another 20 seconds to appear. In that time the wifi network always shows me an error icon. When LS finishes to start the wifi network reconnects and everything works normally.

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Oct 30, 2018 11:57 am
by Borg
LS 4.3 Nightly (5224) tested with Mojave, sadly no improvements.

I SUPPOSE the little snitch staff is reading... but they seems not even interested in working WITH us to solve the problem. Perhaps we are only supposed to try the nightly builds and to have faith in Objective Development ;)

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Oct 30, 2018 12:15 pm
by Bruno
I hop the staff is reading this massive issue.
i do not know if at Objective Development they have a beta test plan ?
How to make them a return?
I have already sent some mail in the past but I never had an answer


Well i test this morning a new cold boot with the latest 4.3 nightly (5224) and it seem to be "ok" now.

But the boot sequence is still weird, with the apple logo, and then a black screen,(slow) and then the apple logo and the desktop, but once on the desktop this time everything is ok with DHCP ethernet and WIFI. Local network too off course. I hope it's not random I'll see later when i cold reboot again.

It should be noted that the boot sequence of macOS mojave with Little Snitch is really weird.
I also try completely uninstalling Little Snitch to test, at this moment the boot sequence is perfect.

Mojave 10.14 (18A391)
MacBook Pro TB 2017 (Wifi)
MacMini Late 2012 (Ethernet)

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Oct 30, 2018 12:31 pm
by Borg
Maybe is worth pointing out that a cold boot is not enough.

The computer must be shutdown for a while (for example the first boot in the morning).

If I turn off and on in a short period of time the problem not shows up (just like in the reboot).

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Oct 30, 2018 12:44 pm
by Bruno
I just send them an email (support page) with a link to this thread.
I received and automated response with a ticket number.

We'll see, but I think they're aware of the problem if we look at the last nightly change logs :

https://www.obdev.at/products/littlesni ... ghtly.html
(But this fixed was also for Little Snitch 4.2.2 (5207) so ??

Little Snitch 4.3 nightly (5224)
Bug Fixes

Fixed: The status of rule groups “macOS Services” and “iCloud Services” was not preserved across restarts.
Fixed an issue causing random crashes of the connection alert or the Network Monitor.
Fixed a bug causing a hang during login under some rare circumstances.

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Oct 30, 2018 3:46 pm
by Volsfandan
I am having the same issues in Demo Mode. If this gets fixed properly, then I will buy your product.

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Wed Oct 31, 2018 10:23 am
by Bruno
Hi,

Objective Development support just answered on that, they are aware and they saw this thread :

We are currently investigating this issue, it seems that it takes some time to load all Little Snitch components at the first restart after a Little Snitch update.
Unfortunately so far we do not know why this would happen at every restart, we were not able to reproduce this.
Kind regards from Vienna,


It should be noted that this does not occur only at the time of rebuilding caches at each update, but anytime after a cold restart.

I asked them if they needed logs.

However, for the moment with the 4.3 nightly (5224), it seems that this does not happen anymore (except the black screen at the boot some time after the apple logo and before the desktop) and this also with the recent update 10.14 .1 (18B75)

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Nov 06, 2018 7:49 pm
by 10w73
I can confirm that it is like most of you said. Massive boot delays when installed (even with the latest nightly 5231). After uninstalling Little Snitch booting was fast as always. Do you guys use Filevault 2? My internal SSD (MBP 13" late 2016) is APFS encrypted. Maybe this helps for further investigation.

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Tue Nov 06, 2018 8:01 pm
by Bruno
Hi,

No filevault here on apfs ssd mojave
Same trouble, and again with the last nightly

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Wed Nov 07, 2018 1:52 pm
by BorisKnowsBest
BorisKnowsBest wrote:Problem fixed now in the newly released nightly build.


Unfortunately, the issue is still present, my previous "hurray" was to optimistic. After return from vacation, the issue is persistent as already mentioned!

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Posted: Wed Nov 07, 2018 4:12 pm
by Bruno
There is a new nightly today (5233) ...

Since I have not had a problem, even with a cold reboot ...