Little Snitch causes massive boot delay (Mojave 10.14)

General discussions about Little Snitch
aintnosnitch
Posts: 4
Joined: Sun Jan 13, 2019 8:25 pm

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Postby aintnosnitch » Wed Jan 16, 2019 5:28 pm

JDW1 wrote:This situation is both hilarious and infuriatingly ridiculous at the same time.

My experience may not necessarily help anyone, but here were my symtoms. My worst-case was 3-5 minute boot to login screen, and after login the system would hang 4 out of every 5 logins following a reboot, necessitating a hard shutdown. The next login would usually be successful, and the system would be fully functional after about 1-4 minutes. About three months ago I did a clean install of Mojave but the symptoms were exactly the same after reinstalling or migrating applications from backup.

Little Snitch has been the first app that I install after a wipe/reinstall since the v1 days, so I wasn't even looking at it as being the potential problem.

I was definitely luckier than some, but still infuriating to have to do frequent hard shutdowns to fix the problem.

hershmaster
Posts: 1
Joined: Sat Jan 26, 2019 4:59 pm

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Postby hershmaster » Sat Jan 26, 2019 5:03 pm

After running nightly build 5237 for several weeks, I think it's safe to say that it worked for me. Before I was experiencing 4-5 minute boot times. Now I'm at about 30 seconds (I use FileVault on a 2018 MBP, so this just fine).

grdh20
Posts: 13
Joined: Fri May 15, 2009 7:41 pm

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Postby grdh20 » Sat Jan 26, 2019 5:40 pm

The latest Mojave OSX update seems to have fixed the boot delay for the most part, but I just ran the latest LS update and on installer reboot got:

{"caused_by":"macos","macos_system_state":"running","bug_type":"210","os_version":"Bridge OS 3.3 (16P3133)","timestamp":"2019-01-26 15:24:15.37 +0000","incident_id":"141A9568-3F86-4EFA-BC9F-814D37D1F1D0"}
{

Anyone else seeing bridge os kernel panics (T2 chip macs only have this)?

aonez
Posts: 1
Joined: Thu Jan 31, 2019 2:47 pm

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Postby aonez » Thu Jan 31, 2019 2:56 pm

Just want to share that I've also faced this issue. Reinstalled a fresh Mojave and got the issue again. Booting in verbose mode showed me there was delays in kext boots, so uninstalled VirtualBox (it installs some kexts). But the issue somehow appeared again.

Just today checked the "show pre-release versions" tick in Little Snitch and saw the bugfix form r5237 mentioning Mojave boot times, and just remembered the other application I've installed with kext is Little Snitch... So just installed the latest r5250 and the boot was as fast as it can be. Will post here if I got another slow boot mentioning some kext load delays.

mainfram2
Posts: 2
Joined: Wed Feb 06, 2019 12:04 pm

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Postby mainfram2 » Wed Feb 06, 2019 12:21 pm

I made the same experience with my MBP 2018 (T2). Long-lasting boot times about 5 minutes etc. My iMac 2017 (no T2) had no problems at all. Both machines run with the same software level macOS 10.14.2 Mojave. After reinstalling 10.14.2 from scratch I installed little snitch 4.2.4. The problem occured again.
I ran little snitch and micro snitch more than a decade. Does anyone know why this problem occurs?

mainfram2
Posts: 2
Joined: Wed Feb 06, 2019 12:04 pm

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Postby mainfram2 » Wed Feb 06, 2019 1:34 pm

In addition: Little Snitch Nightly Built 5250 fixes the problem on MBP 2018. The boot process now run quick again. (In parallel virtualbox 5.2.26 was installed over virtualbox 5.2.24.) The main problems occurred in the past after days of inactivity on the MBP. And they always occur on MBP 2018 only. Not on iMAC 2017.

JDW1
Posts: 6
Joined: Thu Feb 24, 2011 2:30 am
Location: Japan

Re: Little Snitch causes massive boot delay (Mojave 10.14)

Postby JDW1 » Thu Feb 07, 2019 2:10 am

My questions is a bit different from everyone else. Here it is...

WHY IS IT TAKING OBJECTIVE DEVELOPMENT SO LONG TO FIX?

Seriously. It's not like the problem was discovered yesterday, last week, or even last month. This has been going on for a while now, even with new MacOS updates. What in THE world is taking so long? Can we please hear from Objective Development engineers on this? At the very least it would help Little Snitch users to better understand what's going on. Nobody likes being left in the dark.

Thanks.


Return to “Little Snitch General”

Who is online

Users browsing this forum: No registered users and 2 guests