Convert to Global Rule not working in 4.2 with Mojave

General discussions about Little Snitch
Posts: 1
Joined: Mon Oct 01, 2018 6:31 pm

Convert to Global Rule not working in 4.2 with Mojave

Postby st3ff » Mon Oct 01, 2018 6:47 pm


last weekend I upgraded my Mac to Mojave and also upgraded to Little Snitch version 4.2. Since then I'm not able to convert user rules to global rules persistently. When I select one or more user rule(s) and right click the selected, and click on convert to global rule ("In globale Regel umwandeln") the symbol of the rules selected change to the global one. But if I close the Little Snitch Configuration UI and re-open it, the rules are still user-specific rules and not global rules. This feature previously worked very well and is a great for multi-user systems.

If I double-click a rule and change the rule type to global in the rules detail view, it will be persistent. But this is quiet inefficient doing this for many rules one by one. So.. is there anything I can do to get it working again?

Already updated to version 4.2.1 a view minutes ago, but the problem is still there.


Posts: 1
Joined: Fri Jan 04, 2019 1:03 pm

Re: Convert to Global Rule not working in 4.2 with Mojave

Postby spamsandwich » Fri Jan 04, 2019 1:09 pm

Seeing the same here with Mojave 10.14.1 (fresh install though) and Little Snitch 4.2.4 (5210)

Becoming a real pain with multiple family user profiles to have to set rules on each individually.

I have one global rule which has stuck but other rules which are identical except for the hostname used, do not.

Have tried applying the rule and using the padlock but as soon as I quit and go back in, it's gone again.

Return to “Little Snitch General”

Who is online

Users browsing this forum: No registered users and 8 guests