Update 4.2 problem

General discussions about Little Snitch
Post Reply
Walter
Rank 3
Rank 3
Posts: 103
Joined: Fri Nov 24, 2006 6:09 pm

Update 4.2 problem

Post by Walter » Fri Sep 21, 2018 6:32 pm

macos high sierra 10.13.6

iMac Desktop

It took 2 restarts to update from 4.1.3 .

The first restart completely shut down my computer and then i had to manually do a restart whereby the second restart did the update.

Anyone else had problems with this 4.2 update ?

soundog
Posts: 3
Joined: Wed Feb 29, 2012 7:45 pm

Re: Update 4.2 problem

Post by soundog » Sat Sep 22, 2018 8:48 am

Yes. The installation stalled while deleting the older application (eternal beach ball). I had to force quit, and now Little Snitch won't load.

Walter
Rank 3
Rank 3
Posts: 103
Joined: Fri Nov 24, 2006 6:09 pm

Re: Update 4.2 problem

Post by Walter » Sat Sep 22, 2018 6:24 pm

ouch...

with no intention to offend you may i suggest you try a " Safe Boot " restart

information is available at this web site

i always resort to the " Safe Boot " restart when things go wonky and my commercial utilities such as TechToolPro 10 and DiskWarrior 5 can't seem to save the day for me

and I apologize if you know all this stuff

https://www.lifewire.com/how-to-use-mac ... =list_macs

soundog
Posts: 3
Joined: Wed Feb 29, 2012 7:45 pm

Re: Update 4.2 problem

Post by soundog » Sat Sep 22, 2018 8:01 pm

Thanks, Walter for the gentle reminder about a Safe Boot! That did the trick, and I was able to run the 4.2 installer again without a hitch. Up and running smoothly. Best to you....

Trebor229
Posts: 1
Joined: Mon Sep 24, 2018 5:07 pm

Re: Update 4.2 problem

Post by Trebor229 » Mon Sep 24, 2018 5:17 pm

Mac OS 10.13.6. Ran the Little Snitch update to 4.2 today and now on startup it shows a login screen. I have auto login set so I usually don't see that screen. Has name and password spots but when I enter info it indicates wrong info. Started up in safe mode and get the same screen. Started up in recovery mode, installed new system and on startup get the same screen. Booted up from an external drive and ran First Aid in Disk Utility with same result. Looking for other options before I have to erase, reformat and install new system.

Walter
Rank 3
Rank 3
Posts: 103
Joined: Fri Nov 24, 2006 6:09 pm

Re: Update 4.2 problem

Post by Walter » Mon Sep 24, 2018 7:06 pm

double ouch

Now this is only a suggestion :

I would completely uninstall LittleSnitch however since LittleSnitch does not have a built in uninstaller i would use a programme such as AppDelete http://www.reggieashworth.com/appdelete
and then start all over again by installing a fresh copy of LittleSnitch 4.2

now there are other similar programmes but I have always had success with using AppDelete so to me it was worth purchasing many years past

( rant: where is the developer to help us since his web page does not even come close to this problem )

if you don't mind please let us know if that worked or if you solved it without uninstalling/re-installing

good luck

Post Reply