codesignature problem

General discussions about Little Snitch
Posts: 3
Joined: Thu Jun 14, 2018 2:46 pm

Re: codesignature problem

Post by » Thu Jun 14, 2018 3:10 pm

I have the same issue:


Posts: 3
Joined: Wed Jun 13, 2018 7:57 pm

Re: codesignature problem

Post by flynnoeh » Thu Jun 14, 2018 5:42 pm

user425890uhh wrote:
esseti wrote:
RockGrumbler wrote:I have experienced this bug as well. In the initial warning I choose to ignore and nothing happens. I found a work around by using the link at the top of the dialogue window that exposes the rule. This brings up the rule in the configuration app. Then I chose to edit the rule, change nothing, and hit OK. After this I am prompted with a question to ignore code signatures. When I agree at this point, it seems to take effect and the problem is resolved, or at least the code signature is ignored. I'm on OS X 10.13 and using a Cisco VPN client.

this workaround actually works.

- edit the rules and do nothing
- edit the rules and uncheck " code signature checking"
- disable the bloking rule

at least now something works, let's see how long it last

The check box and text to disable code signature checking for my AnyConnect rules is grayed out. I'm unable to disable code signature checking for those rules. :(

Same here.

Posts: 1
Joined: Sat Jun 16, 2018 8:41 pm

Re: codesignature problem

Post by dwrubel » Sat Jun 16, 2018 8:43 pm

I had a similar problem with my Citrix client after the update. Deleting the rule and recreating it solved the problem.


Posts: 4
Joined: Thu Oct 05, 2017 12:02 am

Re: codesignature problem

Post by bluloo » Tue Jun 19, 2018 5:32 pm

FYI, installation of the most recent nightly 4.1.1 (5169) fixed the code signature and crash issue for me - at least so far.

Posts: 1
Joined: Wed Jun 20, 2018 6:55 pm

Re: codesignature problem

Post by tthomas » Wed Jun 20, 2018 7:08 pm

I also had this problem with Cisco AnyConnect Client v. 4.5.04029, Little Snitch 4.1 5167, and macOS 10.13.6 Beta (17G47b). Specifically, the component vpnagentd had all outgoing connections denied, because "The code signature is unacceptable. The certificate used for signing is not trusted." I edited the rule, changed it to allow any outgoing connection, and that fixed the problem--I didn't experience the problem others have where that setting was not honored.

I remember now that I did delete the rule first, and it was created again automatically, and then I edited it.

Posts: 1
Joined: Thu Jun 21, 2018 1:30 pm

Re: codesignature problem

Post by Kammajaga » Thu Jun 21, 2018 1:37 pm

Unbelievebable. I need Cisco VPN for my work and have to disable LS completely to get it connecting.


Hallo obdev!

Posts: 1
Joined: Mon Jun 25, 2018 11:41 pm

Re: codesignature problem

Post by karlegas » Mon Jun 25, 2018 11:43 pm

Looks the new release suppose fix the issue with the valid code signature
Little Snitch 4.1.1 nightly (5169)

Connection Alert: Fixed an issue causing the update of a rule’s code signature information to fail under some circumstances, leading to repeated “code signature mismatch” warnings.
Little Snitch Configuration: Editing a rule’s “Require valid code signature” setting now better handles the case when an exutable’s code signature on disk no longer satisfies the code signature requirement of the rule.

But in my case is not working, I have a problem with QuarkXpress and my copier/printer Konica bizhub 1070, when try to choose the paper tray and select the paper cannot connect to the copier. I can send files to print but I need force the paper tray in the copier.

On Jun 25, 2018, QuarkXPress 2017 via bizhub_PRESS_1070_ui tried to establish a connection to The request was denied automatically during Silent Mode because the code signature does not match what existing rules require.

UPDATE: I reviewed the rules and disable the not allow and now is working but maybe later could be activate new ones. I will keep informed.

Posts: 4
Joined: Thu Sep 07, 2017 5:01 pm

Re: codesignature problem

Post by user425890uhh » Wed Jun 27, 2018 1:22 pm

After updating to the 4.1.1, the "ignore signature" function in Little Snitch is fixed for me.

However, I am still left wondering why the code signature for Cisco AnyConnect is seen by Little Snitch as being invalid when the code signature appears fine when checked within High Sierra itself. Something is still off here.

Posts: 5
Joined: Mon Apr 25, 2016 8:35 pm

Re: codesignature problem

Post by littleratlover » Sat Sep 22, 2018 11:11 pm

With LS 4.2 and Cisco 4.6.01098 the code signature problem persists for me.

Post Reply