Mac doesn't start after installing Little Snitch 4.0.5

General discussions about Little Snitch
imjusthere
Posts: 1
Joined: Tue Jan 23, 2018 8:41 pm

Mac doesn't start after installing Little Snitch 4.0.5

Postby imjusthere » Tue Jan 23, 2018 8:45 pm

Hello!

Just today I reinstalled my Macbook Pro (Running High Sierra). I Shortly after installed the lastest version of Little Snitch (4.0.5). The software needed the computer to reboot, so I did.
After that it could not load again? After I enter my password, I load almost to the end, but stops, and doesn't load any further?

- Currently I'm about to reinstall the computer again... Is this a know issue? Dare I risk installing it right away again?

resourcesforlife
Posts: 1
Joined: Thu Jan 25, 2018 5:04 am

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby resourcesforlife » Thu Jan 25, 2018 5:10 am

I had this same problem, and read elsewhere of others being unable to start their computer. Suggested methods for recovering didn't work for me. I was using macOS High Sierra 10.13.2, but updated recently to the 10.13.3 macOS. Fortunately, I had a backup. Is there any official word on what's happening and when a fix will be issued? I'd like to try installing again, but having to restore my system from a TimeMachine backup is time consuming. Any assistance would be much appreciated.

Konqi
Posts: 3
Joined: Thu Jan 25, 2018 9:45 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby Konqi » Thu Jan 25, 2018 9:48 pm

Had the same problem today, 15" 2017 MacBook Pro.

Even secure boot (pressed shift-kex on start) didn't help. macOS 10.13.3 hangs at the moment when hardware support is loaded.
Only a recovery start with new installation of macOS solved the problem.

zamson
Posts: 1
Joined: Mon Jan 29, 2018 8:23 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby zamson » Mon Jan 29, 2018 8:25 pm

Same problem. Can't even access my HD in terminal so can't delete the Kext file as advised in earlier threads. Very annoying.

Is there any way to solve this without complete reinstall?

AlexN123
Posts: 1
Joined: Tue Jan 30, 2018 9:41 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby AlexN123 » Tue Jan 30, 2018 9:52 pm

I've just experienced the same issue with most recent Little Snitch and macOS High Sierra with most recent updates installed.

The installation went just well, I followed all the instructions and gave all the permissions. The installer asked me to reboot the computer, I did the reboot and it won't boot anymore. The login screen appears I enter my password, the progress bar appears. It goes all the way to 80%, then freezes. Then after a minute or so screen goes black.

Tried all the standard things, like safe mode, SCM reset, etc -- no result.

What helped me to solve the problem:
1. Boot to Recovery (with CMD + R or CMD + Shift + R if you don't have recovery partition)
2. First, pick Disk Utility, select your main disk and Mount it; this is required if your disk is encrypted and requires password to be mounted
3. Now select Disk Utility -> Quit; then Utilities -> Terminal
4. cd /Volumes/<your system's drive name>
5. rm -rf Library/Extensions/LittleSnitch.kext
6. quit the terminal and restart

Konqi
Posts: 3
Joined: Thu Jan 25, 2018 9:45 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby Konqi » Tue Feb 13, 2018 1:27 pm

Can we expect a bugfix for this problem or are we a small number of users with this? :wink:
At the moment I am a little bit scared to try another installation of 4.0.5 under 10.13.3.

smn
Objective Development
Objective Development
Posts: 12
Joined: Thu Aug 06, 2015 11:35 am

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby smn » Thu Feb 15, 2018 11:31 am

Sorry for your troubles.

We are aware of a few users with such issue at our tech-support but unfortunately have not been able to narrow down the problem yet and are still investigating.

For some users safe-mode did help, others had to boot from the recovery partition and reinstall the macOS system files.

Since Little Snitch triggers an update of the kernel cache at the end of its installation routine, this can be about an issue with any installed kernel extension.

In any case it would be worth a try to start in verbose mode (press Command-V at startup) to get any further hints on where the system hangs.

molnarsimon
Posts: 1
Joined: Thu Feb 22, 2018 11:39 am

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby molnarsimon » Thu Feb 22, 2018 12:04 pm

This is my experience with updating from LS3 to LS4 on a High Sierra MacBook Pro. I am seeking advice.

I have been using LS for quite a few years now.

I think I was using the latest LS, as I always let it update when it asks permission to do so.
Incidentally, last time I updated to LS4 and during installation, I realized it was not a free update.
I did not intervene with the installation, let it complete, then let LS4 restart the Macbook.

Macbook chimed, the white screen appeared with the progress bar in the middle. A very slow progress bar. Very-very slow. It did not reach the end of the bar for several _minutes_ (!). After around 5-10 minutes I pressed the power button to shut down the Macbook.

Started again, and pressed the SHIFT key. Macbook chimed, the white screen appeared with the progress bar in the middle. A very slow progress bar. It completed, however, and the login screen came up in 'safe mode' or whatever it was written in red.

So I downloaded the last version of LS3 from the obdev site and installed it over the LS4.

The MacBook - still very slowly - restarted and fully booted after the install.

I happily (NOT!) worked with it for a week or so (I am not sure, an automatic system update may have been performed one night), then decided to restart this morning.

Remember, I reverted back to the latest version of LS3.

Macbook chimed, the white screen appeared with the progress bar in the middle. A very slow progress bar. Very-very slow. It did not reach the end of the bar for several _minutes_ (!), again. When it finally filled the progress bar space (whatever it is called), it has been about 20 minutes already, and then nothing happened (visually) for more than 5 minutes. No login screen just the white screen with the completed progress bar.

So I pressed the power button to shut down the MacBook.

Started again, with the SHIFT key, watched the boot bar slowly fill, logged in, downloaded LS3 installer, run the uninstaller (kept the rules in Library), let it restart the MacBook, and the computer booted under a minute to the login screen.

So, now I do not use LS. 'Is it safe?' :-)

Please assist in deciding:

Should I try installing the latest LS 3 again? I see no reason to abandon LS3 if it works and lets other parts of the system work, so I do not plan to install and pay for LS4.

I guess LS3 was not letting the system boot properly because it may have some entanglements with remnants of the LS4 installation.

cmaylone
Posts: 1
Joined: Thu Feb 22, 2018 3:54 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby cmaylone » Thu Feb 22, 2018 3:57 pm

Same issue. Had to boot to recovery and remove LittleSnitch.kext as outlined above. MBP 2016 15" - 10.13.3.

Roadsider
Posts: 1
Joined: Thu Feb 22, 2018 4:34 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby Roadsider » Thu Feb 22, 2018 4:37 pm

Have to chime in here and confirm this problem.

Last night, I attempted to install the nightly build, but the installation process returned an error. Hoping that this didn't damage my OS, I shut down and went to bed. This morning, I woke to find that I get to spend the day restoring from a backup.

ObDev, you really screwed up this time. :x

john.h
Posts: 1
Joined: Mon Feb 26, 2018 9:38 am

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby john.h » Mon Feb 26, 2018 10:00 am

I run in the same Problem whit the Version 4.0.5 on my Mac Book with macOS High Sierra 10.13.3

The Problem could be solved like AlexN123 has described. (Thanks, AlexN123).

Her where my boot did hang:
.

Code: Select all

en0: DAD complete for 2a02:1203:ecba:a570:d9b2:2f1:ad7d:531b - no dublicates found.
In6_eventhdlr_callback Event IN6_ADDR_MARKED_DEPRECATED received for 2a02:1203:ecba:a570 …


3 minutes

Code: Select all

IOConsoleUsers: time(0) 0->0, lin 0, llk1,
IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm0x0


After 5 minutes

Code: Select all

IOConsoleUsers: time(0) 0->0, lin 0, llk1,
IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm0x0


5 minutes later

Code: Select all

IOConsoleUsers: time(0) 0->0, lin 0, llk1,
IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm0x0


5 minutes later

Code: Select all

IOConsoleUsers: time(0) 0->0, lin 0, llk1,
IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm0x0

kamilbrk
Posts: 1
Joined: Sat Mar 03, 2018 5:07 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby kamilbrk » Sat Mar 03, 2018 5:13 pm

Same issue here, stuck on the boot screen with the same set of messages being last in the verbose mode.

I spent a long while on this going crazy, since there's no LittleSnitch.kext file in /System/Library/Extensions that I automatically assumed to check in recovery mode. Don't make the same mistake and read instructions carefully, it's was in /Library/Extensions.

System works after the kext has been moved somewhere else, but LS Config window welcomed me after a login like nothing happened. What is the kext for, for blocking connections during boot/before login? Apart from this it seems that it actually blocks connections etc.

r2a2ob
Posts: 7
Joined: Mon Feb 19, 2018 10:13 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby r2a2ob » Mon Mar 12, 2018 9:30 pm

Has this been fixed? I'm still on MacOS 10.12.6 Sierra and am hesitant to upgrade to High Sierra.

georges
Posts: 1
Joined: Thu Mar 15, 2018 12:17 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby georges » Thu Mar 15, 2018 12:20 pm

Chiming in here with the same issue.

High Sierra, 10.13.3
15" Macbook Pro 2017

I had to reboot into Recovery with Cmd-R and manually rm the .kext file.

I must admit, I was panicking for a while there. This is a very serious issue.

86pgyi3bejrhu
Posts: 1
Joined: Thu Mar 15, 2018 3:08 pm

Re: Mac doesn't start after installing Little Snitch 4.0.5

Postby 86pgyi3bejrhu » Thu Mar 15, 2018 3:16 pm

Wow, it is totally unacceptable to have such a bug without warnings on your homepage, while the bug is known for such a long time already. I completely panicked.

After removing the .kext file I was able to boot again. However, Little Snitch is not functioning at all "Error connecting to kernel extension". Is there a way to fix this, so I can start using Little Snitch.


Return to “Little Snitch General”

Who is online

Users browsing this forum: No registered users and 7 guests