LS 4 install fails - can't 'allow' install in system prefs!

General discussions about Little Snitch
doesn0tw0rk
Posts: 2
Joined: Sun Oct 22, 2017 4:12 pm

LS 4 install fails - can't 'allow' install in system prefs!

Postby doesn0tw0rk » Sun Oct 22, 2017 4:14 pm

Hey,

I am on MacOSX 10.13 and downloaded the latest version of Little Snitch.
When I open system preferences like explained here: https://www.obdev.at/products/littlesni ... notes.html and click on 'allow' - nothing happens at all.
Uninstalled / Installed LS again, but the error persists. I can click the 'allow' button as often as I want but nothing happens :(

Any help please?

gutschik
Posts: 3
Joined: Thu Oct 26, 2017 10:33 am

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby gutschik » Thu Oct 26, 2017 10:37 am

Same here. I'm stuck...

macOS High Sierra 10.13

Image

doesn0tw0rk
Posts: 2
Joined: Sun Oct 22, 2017 4:12 pm

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby doesn0tw0rk » Sat Oct 28, 2017 7:02 am

Exact same issue.. no one?

lancewhite
Posts: 1
Joined: Fri Nov 03, 2017 4:33 pm

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby lancewhite » Fri Nov 03, 2017 4:34 pm

I'm having the same issue with 10.13.1. Unable to grant access in security.

loa
Posts: 2
Joined: Fri Nov 10, 2017 12:28 pm

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby loa » Fri Nov 10, 2017 12:32 pm

Exactly the same issue. Pressing allow does nothing.

osx 10.31.1
little snitch 4.0.3

loa
Posts: 2
Joined: Fri Nov 10, 2017 12:28 pm

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby loa » Mon Nov 13, 2017 3:00 pm

I just got Little Snitch working... very strange.

I installed Karabiner-Elements which also want to load system extensions. So when I pressed load in Security & Privacy a list appeared with both Karabiner-Elements and Little Snitch. When I choose both and pressed load then Little Snitched started successfully....

So I guess a work-around for others having the same issue is to trigger same as me, install karabiner and make sure to load both extensions.
https://pqrs.org/osx/karabiner/

gutschik
Posts: 3
Joined: Thu Oct 26, 2017 10:33 am

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby gutschik » Wed Nov 15, 2017 3:55 pm


skycaptain
Posts: 1
Joined: Fri Jul 28, 2017 11:31 pm

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby skycaptain » Wed Nov 15, 2017 8:48 pm

loa wrote:I just got Little Snitch working... very strange.

I installed Karabiner-Elements which also want to load system extensions. So when I pressed load in Security & Privacy a list appeared with both Karabiner-Elements and Little Snitch. When I choose both and pressed load then Little Snitched started successfully....

So I guess a work-around for others having the same issue is to trigger same as me, install karabiner and make sure to load both extensions.
https://pqrs.org/osx/karabiner/


Thank you. Worked for me. I already had Karabiner installed, but reinstalling turned back the allow button.

gutschik
Posts: 3
Joined: Thu Oct 26, 2017 10:33 am

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby gutschik » Thu Nov 23, 2017 12:55 pm

Installing Karabiner didn't work for me.

But I finally got it working by uninstalling MagicPrefs. Pretty strange though... Seems like MagicPrefs disabled the "Allow" Button completely.

Got the hint from this issue on github:
https://github.com/tekezo/Karabiner-Ele ... ssues/1017

baude
Posts: 1
Joined: Wed Nov 29, 2017 5:41 pm

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby baude » Wed Nov 29, 2017 5:44 pm

Hello i have the exact same problem...nothing of the solutions help (Karabiner, MagicPrefs...)
Someone has another solution?
Thank you!
Christian

Bluebeep
Posts: 1
Joined: Wed Jun 27, 2018 9:45 pm

Re: LS 4 install fails - can't 'allow' install in system prefs!

Postby Bluebeep » Wed Jun 27, 2018 9:47 pm

The only thing I was able to find is to be physically at the Mac to press this Allow button. If you're using some kind of screensharing (TeamViewer, VNC, etc) that Allow button will do nothing.

Hope this helps someone.


Return to “Little Snitch General”

Who is online

Users browsing this forum: No registered users and 3 guests