LS 4.0.1 broke startup of High Sierra b3

General discussions about Little Snitch
mkummer
Posts: 8
Joined: Fri Nov 26, 2010 5:21 pm

LS 4.0.1 broke startup of High Sierra b3

Postby mkummer » Wed Jul 26, 2017 10:14 pm

V. 4.0.1 came up this morning with a message for installation. I run a public beta 3 of High Sierra on my 5k iMac w/o problems. After the installation the restart of the system went as usual until the progression bar of the startupscreen under the white Apple was full. Even after lunchbreak of 1 h the Mac had not started but was stuck. An additional startup did not change anything. I tried as proposed starting in save mode, but the startup did not finish either. No I am on a dead end and have no idea or option what to do next to get my macOS back. Any help would be greatly appreciated.

Thanks, Michael

walkindude
Posts: 3
Joined: Wed Jul 26, 2017 10:38 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby walkindude » Wed Jul 26, 2017 10:42 pm

Same here.
Booted into Recovery and removed LittleSnitch.kext from /Library/Extensions/ of my system (not recovery's) through Terminal. It helped.

mkummer
Posts: 8
Joined: Fri Nov 26, 2010 5:21 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby mkummer » Wed Jul 26, 2017 11:03 pm

Thanks - since I am not a „terminal man“ - can you be more specific, what exactly you did?

Mk

komodo
Posts: 3
Joined: Wed Jul 26, 2017 10:56 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby komodo » Wed Jul 26, 2017 11:20 pm

Same mac (iMac (Retina 5K, 27-inch, Late 2014)). Same problems. Had to re-install OS (bêta 10.13 (17A315i).
Working fine now.
LittleSnitch still there and working.
LittleSnitch.kext still in system extensions.

walkindude
Posts: 3
Joined: Wed Jul 26, 2017 10:38 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby walkindude » Wed Jul 26, 2017 11:26 pm

- Booted into Recovery
- Launched Terminal
- Ok, maybe the following step is a little bit weird.. but for me it was the quickest path - launched 'Disk Utility' from it, like:
/Applications/Utilities/Disk\ Utility.app/Contents/MacOS/Disk\ Utility
In Disk Utility I mounted my system's drive.
- Closed 'Disk Utility'
- In Terminal I removed the following directory:
rm -rf /Volumes/<your system's drive name>/Library/Extensions/LittleSnitch.kext
or just rename it somehow.
- Rebooted
- Spinning circle, after which system successfully booted.

mkummer
Posts: 8
Joined: Fri Nov 26, 2010 5:21 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby mkummer » Thu Jul 27, 2017 12:53 am

komodo wrote:Same mac (iMac (Retina 5K, 27-inch, Late 2014)). Same problems. Had to re-install OS (bêta 10.13 (17A315i).
Working fine now.
LittleSnitch still there and working.
LittleSnitch.kext still in system extensions.

Hi, how did you re-install?

mkummer
Posts: 8
Joined: Fri Nov 26, 2010 5:21 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby mkummer » Thu Jul 27, 2017 12:54 am

walkindude wrote:- Booted into Recovery
- Launched Terminal
- Ok, maybe the following step is a little bit weird.. but for me it was the quickest path - launched 'Disk Utility' from it, like:
/Applications/Utilities/Disk\ Utility.app/Contents/MacOS/Disk\ Utility
In Disk Utility I mounted my system's drive.
- Closed 'Disk Utility'
- In Terminal I removed the following directory:
rm -rf /Volumes/<your system's drive name>/Library/Extensions/LittleSnitch.kext
or just rename it somehow.
- Rebooted
- Spinning circle, after which system successfully booted.

Thanks for that. Good to know, there is a fallback.

komodo
Posts: 3
Joined: Wed Jul 26, 2017 10:56 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby komodo » Thu Jul 27, 2017 2:20 am

mkummer wrote:
komodo wrote:Same mac (iMac (Retina 5K, 27-inch, Late 2014)). Same problems. Had to re-install OS (bêta 10.13 (17A315i).
Working fine now.
LittleSnitch still there and working.
LittleSnitch.kext still in system extensions.

Hi, how did you re-install?


After hours of trying everything I resolve to try something else.
Pressing D key at startup brings to a screen where one of the 4 choices is to install OS again. Was surprised that it offered HighSierra. Three hours later my mac booted again with the latest beta like if nothing happened. And LittleSnitch was there, doing is things.

Does removing "LittleSnitch.kext" makes the app to become useless?

mkummer
Posts: 8
Joined: Fri Nov 26, 2010 5:21 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby mkummer » Thu Jul 27, 2017 10:06 am

komodo wrote:
mkummer wrote:
komodo wrote:Same mac (iMac (Retina 5K, 27-inch, Late 2014)). Same problems. Had to re-install OS (bêta 10.13 (17A315i).


Does removing "LittleSnitch.kext" makes the app to become useless?

Right now I am reinstalling - hope it works as well.

W/o the LS.kext it does not work.

mkummer
Posts: 8
Joined: Fri Nov 26, 2010 5:21 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby mkummer » Thu Jul 27, 2017 11:13 am

Thanks, the reinstallation did the trick - all is well again. Pew!

Michael

walkindude
Posts: 3
Joined: Wed Jul 26, 2017 10:38 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby walkindude » Thu Jul 27, 2017 12:32 pm

MBP Late 2013
Only one thing changed after reinstallation: grey background to my wallpaper, otherwise the same: booted, entered password, progress bar went fast to approx 85-90%, then slow to 100%, then stuck.

During installation it tells me that
“/System/Library/Extensions/lspcidrv.kext” was installed improperly and cannot be used
by messagebox, pressed the only button, installation continued.

komodo
Posts: 3
Joined: Wed Jul 26, 2017 10:56 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby komodo » Thu Jul 27, 2017 4:49 pm

mkummer wrote:Thanks, the reinstallation did the trick - all is well again. Pew!

Michael


Did you reinstalled OS (version?) or LittleSnitch (version?)

masaga
Posts: 1
Joined: Fri Jul 28, 2017 9:08 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby masaga » Fri Jul 28, 2017 9:13 pm

mine broke too: exact same process...
instead of this procedure (https://www.obdev.at/products/littlesni ... notes.html) it came to this: Image

installed OSX sierra beta new. wanted to try another install of ls 4.0.1 ... same sad story :-(

sqeeezy
Posts: 1
Joined: Sun Jul 30, 2017 11:20 pm

Re: LS 4.0.1 broke startup of High Sierra b3

Postby sqeeezy » Sun Jul 30, 2017 11:26 pm

me too, "fixed" by booting from backup hd and renamimg snitch kext in myHD/Library/Extensions, using Finder to rename as it was just as easy as rm (and I'm paranoid wrt rm ;-)

reboot alles klar

sent email to obdev in case he's not aware of it

btw can i just copy in my old kext from my backup? I'll try anyway

pinami
Posts: 1
Joined: Mon Jan 01, 2018 9:47 am

Re: LS 4.0.1 broke startup of High Sierra b3

Postby pinami » Mon Jan 01, 2018 9:50 am

- In Terminal I removed the following directory:
rm -rf /Volumes/<your system's drive name>/Library/Extensions/LittleSnitch.kext


This Worked. Able to start OS again without a hitch. Little Snitch is also working. Thank you


Return to “Little Snitch General”

Who is online

Users browsing this forum: Google [Bot] and 7 guests