Map not rendering

General discussions about Little Snitch
wtcf90
Posts: 1
Joined: Tue Jul 11, 2017 10:13 pm

Map not rendering

Postby wtcf90 » Tue Jul 11, 2017 10:19 pm

I am having issues with the Map in Little Snitch's Network monitor - it doesn't seem to be rendering, but instead, just shows the map's grid.

Has anyone had any similar issues and / or does anyone suggest whether any Apple and / or Google specific rules might be impacting these? To contradict myself, all my rules at present 'allow' the corresponding incoming connections.

Hoep someone can help

Nairda
Posts: 1
Joined: Thu Jul 20, 2017 11:43 am

Re: Map not rendering

Postby Nairda » Thu Jul 20, 2017 11:46 am

I have exactly the same problem and I suspect it is a deny rule somewhere, but so far I have failed to locate it.

Dweebster
Posts: 12
Joined: Sun Jul 23, 2017 7:00 pm

Re: Map not rendering

Postby Dweebster » Sun Jul 23, 2017 7:07 pm

Same issue here. Freshly installed, no map rendering. macOS 10.11.6 with 2017-003

EMR
Rank 1
Rank 1
Posts: 27
Joined: Tue Nov 18, 2014 5:14 pm

Re: Map not rendering

Postby EMR » Mon Jul 24, 2017 10:33 am

Is your Little Snitch installed on a physical Mac or on a virtual machine? Virtualized OS X/macOS doesn't have hardware acceleration. As a result, you can't use graphics-intensive applications such as Maps.

Dweebster
Posts: 12
Joined: Sun Jul 23, 2017 7:00 pm

Re: Map not rendering

Postby Dweebster » Mon Jul 24, 2017 2:24 pm

Little Snitch is installed on a physical iMac.

EMR
Rank 1
Rank 1
Posts: 27
Joined: Tue Nov 18, 2014 5:14 pm

Re: Map not rendering

Postby EMR » Mon Jul 24, 2017 2:57 pm

Can you see a map showing the Americas, Europe, Asia et cetera, but no network connections?

Dweebster
Posts: 12
Joined: Sun Jul 23, 2017 7:00 pm

Re: Map not rendering

Postby Dweebster » Mon Jul 24, 2017 3:03 pm

The other way around. I see all the connection dots and connection lines, but no map in the background. Can not find a way to upload a screenshot in this forum.

Image

EMR
Rank 1
Rank 1
Posts: 27
Joined: Tue Nov 18, 2014 5:14 pm

Re: Map not rendering

Postby EMR » Mon Jul 24, 2017 6:54 pm

If you open, say, Maps, can you easily find, for instance, Times Square in New York? Can you actually see the site and nearby streets?

Dweebster
Posts: 12
Joined: Sun Jul 23, 2017 7:00 pm

Re: Map not rendering

Postby Dweebster » Mon Jul 24, 2017 7:36 pm

I could, but the LS Helper App was unchecked in Location Services, so LS Helper App was in needs of permission there. Also must grant passage to "wtf.oddev.at" in your firewall (Love that URL folks!). That was blocked by my pfSense instance.

Brilliant tip, EMR! Thanks much.

EMR
Rank 1
Rank 1
Posts: 27
Joined: Tue Nov 18, 2014 5:14 pm

Re: Map not rendering

Postby EMR » Mon Jul 24, 2017 10:14 pm

I'm glad you solved your issue.

roberto
Posts: 4
Joined: Sat Dec 17, 2016 3:30 am

Re: Map not rendering

Postby roberto » Wed Aug 09, 2017 3:48 pm

For anyone still having issues with this; make sure that apple's geod service has access to apple servers:

Image

dennisivy
Posts: 1
Joined: Mon Dec 04, 2017 2:09 pm

Re: Map not rendering

Postby dennisivy » Mon Dec 04, 2017 2:11 pm

still doesn't work for me. at first upon login it works. if i close the main window and reopen it again it doesn't anymore. i don't believe this is a filter issue, i think it's a bug (or feature, but in that case I request a slightly different ft).

rodogone
Posts: 1
Joined: Sat Dec 09, 2017 5:13 pm
Contact:

Re: Map not rendering

Postby rodogone » Sat Dec 09, 2017 5:31 pm

i have the same problem and did what you said. but still not working :(

marco
Objective Development
Objective Development
Posts: 64
Joined: Mon Jul 28, 2014 3:00 pm
Location: Vienna, Austria

Re: Map not rendering

Postby marco » Tue Dec 12, 2017 5:46 pm

There is an issue in macOS 10.12.6 and earlier where geod would sometimes crash, which caused any app that uses Apple’s MapKit framework to only display a grid instead of a map. We contacted Apple about this issue a while ago, but only got the information that this was a known issue. Since this was not reproducible reliably, we don’t know how to test whether this is fixed in macOS 10.13 or not.

Anyway, if you see this issue, there are a couple of things I’d like to know:

  • Which version of macOS is installed?
  • Which version of Little Snitch is installed?
  • Does the Maps app that comes with macOS work correctly when Little Snitch Network Monitor only shows a grid? Or does it also show just a grid?
  • Are there any crash logs for geod in ~/Library/Logs/DiagnosticReports?

newyork10023
Posts: 2
Joined: Mon Jan 01, 2018 5:30 am

Re: Map not rendering

Postby newyork10023 » Mon Jan 01, 2018 6:33 am

I am running Sierra latest (10.12.6 with security updates) and Little Snitch 4.05 (Nightly 5112).

The Little Snitch Network Monitor (LSNM) use to not work at all (completely transparent window where the location of the close button had to be guessed... fun), but one of the recent stable updates fixed the transparent window. The LSNM Map still does not work.

Sometimes I get jibberish (mostly weird text backwards/upside down or just black). The connection dots do seem to show up.

I added Little Snitch rules for geod and locationd. I have enabled Location services in Security & Privacy preferences (ugh!) including for Little Snitch Helper and Maps. This required turning on WiFi (???! and ugh). A couple additional Little Snitch pop-ups appeared when doing this (mostly from my WiFi dish connecting inbound) and they were permitted.

Apple's Maps.app works, including Location. However, LSNM's Map does not.

Latest news: reading the note that Maps is graphics demanding, I had the thought to disable the nVidia driver and use the OS X driver (GTX 680) in nVidia Driver Manager preferences. Reboot, LSNM Maps works (and Apple Maps.app). Reticked nVidia driver, reboot. Doesn't.

Appears that using nVidia's driver instead of OS X driver is the cause (after getting everything else working...).

It was a nifty feature but I would prefer to use nVidia drivers, can this issue receive a fix?


Return to “Little Snitch General”

Who is online

Users browsing this forum: No registered users and 3 guests