Network Monitor does not open in V4.0

General discussions about Little Snitch
y2kplaya
Posts: 3
Joined: Sun Jul 30, 2017 6:50 pm

Re: Network Monitor does not open in V4.0

Post by y2kplaya » Sun Jul 30, 2017 6:53 pm

savf wrote:I had the same problem after updating to Little Snitch 4.0.1 on my Mac Pro with the following configuration:

Mac Pro 3.1 (Early 2008)
macOS Sierra 10.12.5 (16F73)
NVIDIA GeForce GTX 770
NVIDIA Web Driver 378.05.05.15f01

I successfully got the network monitor to work with NVWebDriverLibValFix.kext and the following steps:

  1. Boot into recovery mode by holding Cmd + R (screen stayed black, I kept holding the combination, let go after about 10 seconds and then recovery started)
  2. Open the terminal in recovery mode (Utilities -> Terminal)
  3. Enable system integrity protection but allow unsigned kernel extensions with the following command:

    Code: Select all

    csrutil enable --without kext

    This should return:
    csrutil: requesting an unsupported configuration. This is likely to break in the future and leave your machine in an unknown state.
    Successfully enabled System Integrity Protection. Please restart the machine for the changes to take effect.
  4. Now reboot the Mac normally, download NVWebDriverLibValFix.kext.1.0.0.tar.gz from https://github.com/mologie/NVWebDriverLibValFix/releases, then untar and activate with:

    Code: Select all

    sudo tar -xv -C /Library/Extensions -f NVWebDriverLibValFix.kext.1.0.0.tar.gz
    sudo kextutil /Library/Extensions/NVWebDriverLibValFix.kext


Is this workaround working for everyone?

Any chance Obdev will release a 'Nightly' fix for this bug? No problems on my laptop BTW

Mac Pro 5.1 (Mid 2010)
macOS Sierra 10.12.6(16F73)
NVIDIA GeForce GTX 980 TI
NVIDIA Web Driver 378.05.05.25f01

Little-Feet
Posts: 2
Joined: Tue Jul 25, 2017 6:54 pm

Re: Network Monitor does not open in V4.0

Post by Little-Feet » Sat Aug 12, 2017 5:41 pm

Thank you very much!
Now it's working here (also when i restart the Mac) with the solution below.

Mac Pro 5.1 (Mid2010-upgraded to 2x3,46 GHz 6-Core Intel)
macOS Sierra 10.12.6
NVIDIA GeForce GTX 980 Ti
NVIDIA Web Driver 378.05.05.25f01
Coda Driver Version 8.0.90

I did the process twice. After the first attempt the extension wasn't loaded after a restart. I will give an update in a few days.

Thank you again-Cheers from Hamburg-raining...




Working Solution (xCode is installed)
1. Boot into recovery mode by holding Cmd + R (screen stayed black, I kept holding the combination, let go after about 10 seconds and then recovery started)
2. Open the terminal in recovery mode (Utilities -> Terminal)
3. Enable system integrity protection but allow unsigned kernel extensions with the following command:

Code: Select all

csrutil enable --without kext


csrutil enable --without kext
csrutil: requesting an unsupported configuration. This is likely to break in the future and leave your machine in an unknown state.
Successfully enabled System Integrity Protection. Please restart the machine for the changes to take effect.


4. Now reboot the Mac normally, download NVWebDriverLibValFix.kext.1.0.0.tar.gz from https://github.com/mologie/NVWebDriverLibValFix/releases, then untar and activate with:

Code: Select all

sudo tar -xv -C /Library/Extensions -f NVWebDriverLibValFix.kext.1.0.0.tar.gz
sudo kextutil /Library/Extensions/NVWebDriverLibValFix.kext

y2kplaya
Posts: 3
Joined: Sun Jul 30, 2017 6:50 pm

Re: Network Monitor does not open in V4.0

Post by y2kplaya » Mon Aug 14, 2017 11:26 pm

Afterdownloading .kext file what is process of tar.gz? Should .kext file be dragged to /Library/Extensions then run: sudo tar -xv -C /Library/Extensions -f NVWebDriverLibValFix.kext.1.0.0.tar.gz
sudo kextutil /Library/Extensions/NVWebDriverLibValFix.kext

I'm not a coder so missing a step here. Thanks

rsconsulting
Posts: 1
Joined: Wed Aug 16, 2017 2:29 pm

Re: Network Monitor does not open in V4.0

Post by rsconsulting » Wed Aug 16, 2017 2:32 pm

sgaap wrote:Someone released a tool to fix this issue, have not tested it myself but people are reporting that it works.
Keep in mind that its always a risk to install a 3th party driver (kext).
Its tested against 10.12.5, so maybe 10.12.6 breaks it.

https://github.com/mologie/NVWebDriverLibValFix

Download:
https://github.com/mologie/NVWebDriverL ... x/releases

//edit:

Tested it with 10.12.6 using the 378.05.05.15f01 webdrivers (for 10.12.5, it loads just fine after modifying the osx build check in the plist): ibooks works so little snitch is likely to work also.


Worked fine for me.

hackintosh - Sierra 12.6 - clover/multibeast- Nvidia 1060 web drivers 378.05.05.25f01.

Went to download link, downloaded, ran the two instructions in terminal, re-booted. All Good.

MAKE A NOTE OF THE KEXTS INSTALLED IN TERMINAL - so if it blows up later, you know WHAT TO REMOVE.

Nice to see this working, frustrated since it worked fine on my Macbook Pro (and is a lot cooler than the previous versions applet).

Rick

ah55
Posts: 2
Joined: Fri Aug 25, 2017 1:29 pm

Re: Network Monitor does not open in V4.0

Post by ah55 » Fri Aug 25, 2017 1:33 pm

I've got the same issue, but have fixed it with the workaround...

2012 Mac Pro
3.33
Sierra
Nvidia GTX980 (flashed + web drivers)

Post Reply