Search found 5 matches

Go to advanced search

by ThiefMaster
Mon Mar 17, 2008 12:17 am
Forum: V-USB
Topic: First key is not sent (hid keyboard)
Replies: 11
Views: 9564

Hmm, USB_INITIAL_DATATOKEN is not used anywhere in the driver. :o

Btw, when sending data from my program, is it better to send it only when receiving USBRQ_HID_GET_REPORT or via usbSetInterrupt?
by ThiefMaster
Fri Mar 14, 2008 1:53 pm
Forum: V-USB
Topic: First key is not sent (hid keyboard)
Replies: 11
Views: 9564

First key is not sent (hid keyboard)

Hi, i wrote this code ( http://tm.privatepaste.com/801BrgfCB1 ) based on HIDKeys, but right after connecting it to USB, it only sends "ello\n" when pressing my button on PC0. When i press it again it sends "Hello\n" as intended. Do you have an idea what could be the reason for it...
by ThiefMaster
Thu Mar 13, 2008 10:14 pm
Forum: V-USB
Topic: USB on Mega664 not working
Replies: 5
Views: 3502

Will the AVR work correctly with 3.3V? According to the datasheet, it needs 2.7-5.5V for 0-10MHz and 4.5-5.5 for 0-20 MHz.

Edit: Seems to work fine with 3.5V on the AVR.
by ThiefMaster
Thu Mar 13, 2008 8:20 pm
Forum: V-USB
Topic: USB on Mega664 not working
Replies: 5
Views: 3502

I'll try that later.. Which voltage should the chip have?

Very odd thing: after moving to PD2 (=INT0) and PD3 it works fine when connecting it to my linux pc.. when connecting it to my windows PC I still get the same errors.
by ThiefMaster
Thu Mar 13, 2008 5:27 pm
Forum: V-USB
Topic: USB on Mega664 not working
Replies: 5
Views: 3502

USB on Mega664 not working

Hi, I tried the PowerSwitch example on my Mega644 but the PC always says that the connected USB device could not be detected and doesn't work properly (libusb-win32 is installed and HIDKeys has the same problem). My layout looks like this: D+ -> 68Ohm -> PC2. PC2 <-> INT0 D- -> 68Ohm -> PC0 + -> 1.5...

Go to advanced search