Search found 13 matches

by solata10
Tue Dec 22, 2009 9:57 pm
Forum: V-USB
Topic: bootloaderHID on atmega8535 ?
Replies: 1
Views: 2383

bootloaderHID on atmega8535 ?

hello, i would like to run bootloaderHID on atmega8535, but i'm not sure if its possible. i tried it : 1) uploaded bootloaderHID to my device 2) connected my device to computer, i get device not recognized 3) reconnected my device, this time holding down the "program" button, HID device ge...
by solata10
Tue Dec 22, 2009 7:19 pm
Forum: V-USB
Topic: USB MIDI Interface
Replies: 93
Views: 174379

Re: USB MIDI Interface

hmmm, if i'm correct, this way i can send at most 4 bytes at once right ?
and i have no way to getting back return informations.
by solata10
Tue Dec 22, 2009 3:59 pm
Forum: V-USB
Topic: USB MIDI Interface
Replies: 93
Views: 174379

Re: USB MIDI Interface

hello. i also created a drumset based on your code, and it works ok, however i would like to be able to set few paramaters from computer, like limit at which the note-on gets sent, smoothing level, boost for each drum, note for each drum. does anybody know, what would be the best way to do it ? i wa...
by solata10
Wed Dec 16, 2009 7:35 pm
Forum: V-USB
Topic: why libusb ?
Replies: 2
Views: 2780

why libusb ?

hello.

i'm using windows, and as far as i can understand, for HID devices, you dont need any driver.
so why, all of the examples provided with v-usb use libusb as the way to comunicate with hid devices ?

what are the pros and cons of libusb vs windows hid driver ?

thanks
by solata10
Tue Dec 15, 2009 8:40 pm
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

ok solved, the device was not recognized, becouse i didnt set the frequency of device correctly.
Makefile:

F_CPU = 12000000
by solata10
Tue Dec 15, 2009 7:48 pm
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

ok i've been playing with that blinking led addon to the code, and i managed to make it work, LED_PORT_OUTPUT |= _BV(LED_BIT); turns the led on sucesfuly, however when i try to "sleep" for a second, then nomather, if i use _delay_ms(1000); or if i use for (i = 0; i< 99999; i++) a = 0; the ...
by solata10
Tue Dec 15, 2009 5:15 pm
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

is there some simple firmware i can put on my device which will show if anything on the device side is ok ? (like turn on a led, if usb initialization is ok, and then blink the led if code is executing) i tried puting this in my main.c just before for(;;) in int main() : _delay_ms(5000); LED_PORT_OU...
by solata10
Tue Dec 15, 2009 3:10 pm
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

ok here is schematics for my current board. m notice that i changed chip to atmel 8535. i am trying to run the hid-custom-rq from examples folder of latest v-usb only changed i made are : main.c : line 19 (changed the port the led is connected to) #define LED_PORT_DDR DDRB #define LED_PORT_OUTPUT PO...
by solata10
Tue Dec 15, 2009 2:51 pm
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

i changed the batery in my multimeter, and now it shows 5.2V output of usb and after i connected the 3.6V zener diodes i have 3.0V on D- however its still not working. i will try to assemble new circuit, with just one led and will try to run hid-custom-rq (from v-usb examples folder) i will post my ...
by solata10
Mon Dec 14, 2009 11:18 am
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

i tried measuring voltage on usb port (without device connected. its in the range fro 7.6 till 8V. i also measured it on another computer, and got the same results. then i measured the voltage on standard AA battery, got a reading of 2.2V (it should be 1.5 right?) so i'm guesing my measuring equipme...
by solata10
Mon Dec 14, 2009 11:14 am
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

i set fuses exactly as described in pdf pasted above. avrdude said it was sucesful. i will try to add zener diodes.
by solata10
Sun Dec 13, 2009 10:34 pm
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

Re: USB Device not recognized

hey. yes i detached it from the programming cable.
i'm a little bit confised to. where do i get 7.6 V, if it should be 5 ?
that way even solutions published on a wiki page wouldnt work (well atlest not solutions under B)
by solata10
Sun Dec 13, 2009 3:19 pm
Forum: V-USB
Topic: USB Device not recognized
Replies: 11
Views: 7772

USB Device not recognized

i get this error when i plug my device to usb .... USB Device not recognized. One of the usb devices attached to this computer has malfunctioned ... --------------- the device is like this : [[ m ]] (you can find shcematics on page 6) -> i could sucesfuly connect device to LPT port and program it us...