Search found 5 matches

by kuro68k
Thu Feb 16, 2017 6:58 pm
Forum: V-USB
Topic: jitter in usbdrvasm16.inc
Replies: 1
Views: 3766

Re: jitter in usbdrvasm16.inc

Thanks for this. I'm interesting in integrating it into my code. I've noticed the jitter too. Can you post the complete TX routine? I think the best solution would be to remove the sbrs. There is a nop in didStuff7 so you could replace it with a bst/bld, but not the other two. The only thing I can t...
by kuro68k
Thu Feb 16, 2017 5:31 pm
Forum: V-USB
Topic: XMEGA port
Replies: 3
Views: 4135

Re: XMEGA port

Okay, it enumerates now. I have not tested it extensively but this is a good sign that everything is likely to operate smoothly. For XMEGA there are a few instructions with different timing to MEGA/TINY AVR cores, and some architectural differences like not having the CPU registers mapped into memor...
by kuro68k
Wed Feb 15, 2017 12:10 pm
Forum: V-USB
Topic: XMEGA port
Replies: 3
Views: 4135

Re: XMEGA port

Logic capture, looks like the response is bad perhaps?

Image

http://i.imgur.com/DrwsClJ.png
by kuro68k
Wed Feb 15, 2017 11:57 am
Forum: V-USB
Topic: XMEGA port
Replies: 3
Views: 4135

Re: XMEGA port

I threw the code up on Github: https://github.com/kuro68k/vusb-xmega
by kuro68k
Wed Feb 15, 2017 11:53 am
Forum: V-USB
Topic: XMEGA port
Replies: 3
Views: 4135

XMEGA port

Hi. I have started porting V-USB over to XMEGA. I have it compiling and the Windows PC sees an unknown USB device. Looking at the debugger it appears that packets are being received. The first request that comes in is length 8, and looks like this: bmRequestType 0x80 unsigned char{registers}@0x2066 ...