Search found 5 matches

by rszemeti
Fri Jan 03, 2014 8:36 pm
Forum: V-USB
Topic: Sometimes it does ... sometimes it doesn't
Replies: 3
Views: 2647

Solved

Sorted. At some point I had uncommented the line: // #define USB_INTR_CFG MCUCR in usbconfig.h ... which caused it to work erratically ... for reasons not totally clear to me ... I think I did that while trying to configure for INT2 but anyway commenting that line out again that solved it, and it ru...
by rszemeti
Fri Jan 03, 2014 5:06 am
Forum: V-USB
Topic: Sometimes it does ... sometimes it doesn't
Replies: 3
Views: 2647

Re: Sometimes it does ... sometimes it doesn't

I've tried with stock 'Automator' code, stripped down to essentials, removed all the events and polling with the exception of the usbPoll(); loop ... and still get pretty much the same result .. disconnecting the JTAG debugger and running production rather than debug code seems to make a little impr...
by rszemeti
Thu Jan 02, 2014 5:16 am
Forum: V-USB
Topic: Sometimes it does ... sometimes it doesn't
Replies: 3
Views: 2647

Sometimes it does ... sometimes it doesn't

I'm having a bit of headache with a (modified) version of Automator ... and at least part of the problem seems to be erratic comms. Running #lsusb -D <device path> or opening the device from a random Perl script will either yield the manufacturer name, or the product name, or both, or neither ... de...
by rszemeti
Fri Dec 27, 2013 4:52 am
Forum: V-USB
Topic: Never hits the interrupt
Replies: 2
Views: 2448

Re: Never hits the interrupt

Ah ha! ICS20 & ICS21 ... that did it .. all is good.

It won't run with the JTAG debugger doing it's thing, but its just fine otherwise, thank ye!
by rszemeti
Fri Dec 27, 2013 1:16 am
Forum: V-USB
Topic: Never hits the interrupt
Replies: 2
Views: 2448

Never hits the interrupt

Hi, I'm running the code on an AT90USB1287 ... *not* using the hardware USB, running v-usb to see how it works out. Everything looks right level wise, other code on the system runs fine, my i2c buss is doing its thing, lights lighting etc etc. I can see the 1.5K get pulled high when I call usbConnec...