Search found 16 matches

by ahulap
Thu Nov 27, 2008 9:19 pm
Forum: V-USB
Topic: making USBasp hardware with AVR-Doper 2008-04-27 firmware
Replies: 18
Views: 13879

Green led is used like "ON" indicator. But all who build USBasp and use your firmware will have a "dead" led, this does not look good... I have rebuild AVR-Doper firmware and turn it on. Is there any way to compile USDasp-Doper for ATmega48, HID-only, without debug? I've got arou...
by ahulap
Thu Nov 27, 2008 8:08 pm
Forum: V-USB
Topic: making USBasp hardware with AVR-Doper 2008-04-27 firmware
Replies: 18
Views: 13879

I have tested it (precompiled usbasp-mega8-12mhz.hex), and it works!
But one little thing left: USBasp have 2 LEDs, and green (PC0) is always off. Maybe set it on forever in hardwareInit()?
by ahulap
Fri Nov 21, 2008 9:57 am
Forum: V-USB
Topic: making USBasp hardware with AVR-Doper 2008-04-27 firmware
Replies: 18
Views: 13879

I have a 2 versions of USBasp: with original schematics and very simplified (without LEDs, jumper, and D+ and D- moved to PD2 and PD3). Original does not work, but modified works! I think that it is something with PB1 and PB0... and found that TIMER1 is initialized for PWM output for METABOARD_HARDW...
by ahulap
Wed Aug 15, 2007 9:43 am
Forum: V-USB
Topic: AVR-Doper HID mode problem
Replies: 10
Views: 28570

The transistors are probably not a good substitute for level conversion. Why not? 4 NPN transistors are the simplest way to substitute 74HC125. Without any software modifications, i think, it is impossible to implement connection/disconnection of programmer to target: SCK and MOSI are always output...
by ahulap
Tue Aug 14, 2007 8:09 pm
Forum: V-USB
Topic: AVR-Doper HID mode problem
Replies: 10
Views: 28570

I'm still don't undestand. AVR pins have internal pullups in range 20k...100k. With 1k resistor it creates a voltage divider. Voltage on MOSI pin with jumper closed and pull-up enabled will be ~1/21 VCC (with 20k pullup, with larger pullup - even smaller, up to 1/101). In some datasheets minimum low...
by ahulap
Tue Aug 14, 2007 7:21 pm
Forum: V-USB
Topic: AVR-Doper HID mode problem
Replies: 10
Views: 28570

I have rebuild avrdude-5.4 using cygwin. All works, but i have foung strange thing in 'readInterfaceType' function: PORT_DDR_SET(HWPIN_ISP_MOSI); PORT_PIN_SET(HWPIN_ISP_MOSI); // _delay_us(10); PORT_DDR_CLR(HWPIN_ISP_MOSI); PORT_PIN_CLR(HWPIN_ISP_MOSI); /* dea...
by ahulap
Tue Aug 07, 2007 6:08 pm
Forum: V-USB
Topic: USBasp
Replies: 1
Views: 3132

USBasp will support all controllers, witch are supported by avrdude program. To see them, run "avrdude -p?"
by ahulap
Tue Jul 31, 2007 7:39 pm
Forum: V-USB
Topic: PowerSwitch disconnects
Replies: 8
Views: 7150

I doubt that this is a problem with the host side driver. Switching to HID won't help. Yes, i have tested it - no difference But, i think, it is not a controller reset. When D- pull-up is controlled by IO pin, during reset this pull-up is disabled - device disconnects and window plays 'ding' sound....
by ahulap
Tue Jul 31, 2007 7:23 pm
Forum: V-USB
Topic: AVR-Doper HID mode problem
Replies: 10
Views: 28570

It is something with avrdude from WinAVR package. I have downloaded avrdude.exe (from some user post at avrdude homepage) and it's works. Strange...
by ahulap
Mon Jul 30, 2007 7:27 pm
Forum: V-USB
Topic: AVR-Doper HID mode problem
Replies: 10
Views: 28570

I have tested bootloadHID with this hardware and it is works! So, i think, it is alright with HID mode.
I'm using avrdude 5.3.1 from WinAVR-20070525 package (also tryed from WinAVR-20070122). Now i will download cygwin and try to build avrdude myself...
by ahulap
Sun Jul 29, 2007 9:52 am
Forum: V-USB
Topic: AVR-Doper HID mode problem
Replies: 10
Views: 28570

AVR-Doper HID mode problem

I have build simplified version of AVR-Doper and it works in serial port mode, but in HID mode avrdude can't connect to programmer: avrdude.EXE: avrdoper_open(): Device not found. HID device with VID=0x16C0 PID=0x05DF is present and windows says, that it is OK. PS: how to post files here? I want to ...
by ahulap
Thu Jul 26, 2007 1:52 pm
Forum: V-USB
Topic: PowerSwitch disconnects
Replies: 8
Views: 7150

In my case it was not RESET. Firstly i have modified USBasp SW & HW - move D- pull-up to IO pin and watch this pin with oscilloscope - where was no impulses there. Then i have build optically isolated version (with 6N137) - disconnections occurs more rarely, but they not totally gone! In second ...
by ahulap
Wed Jul 25, 2007 6:06 pm
Forum: V-USB
Topic: PowerSwitch disconnects
Replies: 8
Views: 7150

I have the same problems with USBasp programmer (on WinXP). Voltage surges from target (especially on power-up) makes device lost - only reconnection helps. Good, shielded cable helps a lot, but not totally. PS: I have tested avr910 programmer with ft232 mc with the same cables and target - all work...
by ahulap
Fri Apr 27, 2007 1:07 pm
Forum: V-USB
Topic: AVR-Doper problems prog ATMEGA2561
Replies: 6
Views: 5952

In avr068.pdf there is a note about address: "If bit 31 is set, this indicates that the following read/write operation will be performed on a memory that is larger than 64KBytes. This is an indication to STK500 that to load extended address must be executed. " For mega2561 that ISP command...
by ahulap
Wed Mar 07, 2007 4:17 pm
Forum: V-USB
Topic: usb_control_msg length
Replies: 2
Views: 4670

Thank you!